Find the answer to your Linux question:
Results 1 to 5 of 5
Hi All, I really hope some one can help me. I have been trying to create SymLinks on my Linux ES box. The SymLinks that I create work because I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3

    Symbolic Links and Apache


    Hi All,
    I really hope some one can help me.
    I have been trying to create SymLinks on my Linux ES box. The SymLinks that I create work because I can CD to them and I see the files I am meant to see.
    However, what I want to do is use SymLinks that point outside of my /var/www/html directory to /home/somefolder.

    Now, if I create SymLinks that that are within the /var/www/html directory (IE: if I have a SymLink that point to /var/www/html/somedir) it works well, but as soon as I come out of the designated Web space I get 403 errors.

    I have set my httpd.conf to 'Options FollowSymLinks' and I still get no joy.
    In the log the error is that I dont have permission. I have set the folder that the SymLink points to to have a chmod 2777 (extreme I know) and still I dont have permission.

    I have even tried to create an Alias to the same folder and I dont get any joy.

    There must be a way of doing this, after all, how can people like myspace have so many video and audio files in just one web space?

    What I want to do is to have my site hosted in my /var/www/html directory, and have all the uploaded data, images - video and mp3's stored in another location.

    Any help would be greatly appreciated as I have now run out of ideas and my eyes ache from reading forums

    Thanks in advance

    Anadi

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Create a new partition or add a hard disk and mount it on a subdirectory of /var/www/html, (instead of e.g. /mnt/disk2).

    As a test, I just created a directory in my /var/www/html directory and mounted a CD iso file using a loop device (mount -o loop -t iso9660 file.iso /var/www...) and I was able to read text files from the iso remotely.

    As an aside, I just read a post where somebody using NetBSD is mounting one directory on another directory using type "null". It hides the existing directory and allows access to the mounted dir. But Linux doesn't seem to know anything about the null type. Shame--I like the idea.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3

    Thanks :-)

    Hey - thanks for your reply - sorry its taken me a while to get this post, I have been really busy
    I will experiment with mounting devices in my /var/www/html directory

    All the best,

    Anadi

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3
    Hi all,
    Well, I am still struggling with the same problem. I have mounted /home/uploads so that it is mounted within my usable web area (/var/www/html/control/ups) and I still get a permission error when I try to access this directory using PHP. I have also tried to browse to this directory using Firefox and I get the same permissions error: You do not have permission to access /control/ups/ on this server.

    Please help!!!

    Anadi

  5. #5
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    How is /home/uploads mounted on /var/www/html/control/ups?
    Is it mounted in two places at once?
    What mount type are you using?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •