Find the answer to your Linux question:
Results 1 to 5 of 5
My Apache web server works fine, and it is all cozy in /var/www/html/. And I have vsftpd working fine as long as files I want to move are in /home/user/. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    12

    how2 get vsftpd to look at webserv files???


    My Apache web server works fine, and it is all cozy in /var/www/html/. And I have vsftpd working fine as long as files I want to move are in /home/user/. I have vsftpd disallowing annonymous login, and I am pretty sure I have it locked down to just me as a local user. I have tried chmod the /var/... directory from a root terminal. No luck! I have considered a hard link between the directories, but I am doubtful this will work. I have considered mv the /www/... directory to /home/user/ but I don't know how to let httpd know where to look. And whatever I do, vsftpd will not let me out of /home/. (It will let me cd to /var/ but it does not open the directory.) Anyone with insight to share on this vexing problem will be thanked greatly.

  2. #2
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Question

    I'm having the same problem...what did you do to fix it??

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    39
    I have almost tha same problem (in vsftp). I want to make a link into the folder of user1 to target at folder of user2 but it shows the link as a file to download.

    If anyone knows let help us.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    12

    vsftp won't allow it

    I have come to the conclusion that what I was trying to do is impossible with vsftp. It's just the nature of the beast with very secure ftp. Actually, I decided to just use anonymous ftp for everything. Then log onto the server as root and chown and mv the files from the anonymous directory. User id's and passwords are sent in plain text over the ftp protocol. So I don't want to log onto my web server directory over ftp.

  6. #5
    Just Joined! aenguillo's Avatar
    Join Date
    Dec 2006
    Location
    philippines
    Posts
    40
    i tried using vsftp also but i got the same problem. so i used ProFTP instead. no hassle.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •