hi

I installed fedora core3 on a dell laptop inspiron2200. I tried installing bugzilla-2.22 on the linux machine.
perl modules were installed. settings were made in the localconfig file. apache 2.0.52 was installed and the required configuration
were made. I downloaded and installed MySql-server-4.1.18-1.fc3.remi.i386.rpm. upon running checksetup.pl in the bugzilla directory the
required perl modules were checked and the following were found

Appconfig (v1.63), CGI (v3.23), Data:umper(v2.121), Date::Format(v2.22), DBI(v1.40), File::Spec(v0.17), Template(v2.15), Text::Wrap(v2006.0711), Mail::Mailer(v1.74), MIME::base64(v3.01), MIME::Parser(v5.420), Storable(v2.13)

All the perl modules were installed.

Then checksetup.pl gave such errors as
Can't connect to database
Can't connect to local MySql server through socket /var/lib/mysql/mysql.sock (2)
Is your database installed and up and running?
do you have the correct username and password selected in localconfig?

I checked Mysqld service status and it gave such errors as
service dead but subsystem locked

I tried with mysqladmin version. it says unrecognised command.

the file mysql.sock is missing in the directory /var/lib/mysql.

Any help from your side would be highly appreciated

Regards
Gagan