Find the answer to your Linux question:
Results 1 to 5 of 5
Hello! Right now my server has a total of 2 sub-domains. Forums, and Mail. I wish to add another, called jabber, but I wish for it to be on port ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    65

    Virtual Host not at intended address


    Hello!

    Right now my server has a total of 2 sub-domains. Forums, and Mail. I wish to add another, called jabber, but I wish for it to be on port 9000.
    So far this hasn't worked.

    Here is my configuration for the VirtualHosts, with the new vhost appended.

    Code:
    <VirtualHost *:80>
    DocumentRoot /var/www/virtual/forums
    ServerName forums.kylesplace.org
    ServerAlias forums.kylesplace.org
    # Other directives here
    
    <Directory /var/www/virtual/forums>
    
    Options +Includes Indexes FollowSymLinks +ExecCGI     
    
        AllowOverride None
        Order allow,deny
        Allow from all
    
    </Directory>
    
    </VirtualHost>
    
     <VirtualHost *:80>
    DocumentRoot /var/www/virtual/mail
    ServerName mail.kylesplace.org
    ServerAlias mail.kylesplace.org
    # Other directives here
    
    <Directory /var/www/virtual/mail>
    
    Options +Includes Indexes FollowSymLinks +ExecCGI     
    
        AllowOverride None
        Order allow,deny
        Allow from all
    
    </Directory>
    
    </VirtualHost>
    ####
    #jwchat vhost
    Loadmodule jk_module modules/mod_jk.so
    JkWorkersFile /etc/httpd/conf/workers2.properties
    JkLogFile /etc/httpd/logs/mod_jk.log
    JkLogLevel info
    JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
    
    # serve all java server pages from Tomcat
    JkMount /*.jsp ajp13
    <VirtualHost *:9000>
    DocumentRoot /var/www/virtual/jwchat
    ServerName jabber.kylesplace.org
    ServerAlias jabber.kylesplace.org
    # Other directives here
    
    <Directory /var/www/virtual/jwchat>
    
    Options +Includes Indexes +MultiViews FollowSymLinks +ExecCGI     
    
        AllowOverride None
        Order allow,deny
        Allow from all
    
    </Directory>
    
    </VirtualHost>
    Now if you navigate to jabber.kylesplace.org:9000 you'l get the corrrect page. But if you navigate to www.kylesplace.org:9000 you'll also get the correct page. So my question is, how do I stop all subdomains except jabber* from listening on port 9000

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Location
    (.)
    Posts
    69
    I think removing wildcard and placing correct entry there, should work

  3. #3
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    So you don't want a user to have to type whatever.com:9000 you just want apache to forward this to tomcat? Can you browse to your tomcat page and its working fine? Is there anything in any apache error logs?

  4. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    65
    Quote Originally Posted by jledhead
    So you don't want a user to have to type whatever.com:9000 you just want apache to forward this to tomcat? Can you browse to your tomcat page and its working fine? Is there anything in any apache error logs?
    I want the user to type 'jabber.kylesplace.org:9000'. In actuality they won't be typing at all as this is a popup box.
    And www.kylesplace.org:8080 works fine.

    My problem is, the virtual host 'jabber' is not separated from the others. On every one of my sub-domains, you can access this page just by adding :9000 to the end.

    forums.kylesplace.org:9000
    mail.kylesplace.org:9000
    www.kylesplace.org:9000
    kylesplace.org:9000

    I want only want the 'jabber.kylesplace.org:9000' to go to that page.
    Why do the other subdomains respond to that port?

    Quote Originally Posted by mitto
    I think removing wildcard and placing correct entry there, should work
    I think I have tried removing the wildcards before, I will try again.

  5. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    65
    Nope still didn't work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •