Find the answer to your Linux question:
Results 1 to 3 of 3
I have set up samba server sharing a printer and two file system shares: pub and tmp. (located at /var/samb/pub and /var/samba/tmp). /var/samba/pub has been linked to /var/www/html (which is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Location
    Tallinn, Estonia
    Posts
    18

    Samba and Apache problems


    I have set up samba server sharing a printer and two file system shares: pub and tmp. (located at /var/samb/pub and /var/samba/tmp).
    /var/samba/pub has been linked to /var/www/html (which is apache document root). Everything worked as expected until a server reboot caused by a power failure. (I know it's a bad idea running a linux server without UPS, but it's just my home server which I'm using for printer and file sharing and for educating myself about linux.)
    Anyway, Windows workstations can't access samba file shares anymore (an error message says that resource is not accessible and that access is denied) although printing works fine. Also when trying to browse to http://servername/pub/ I get a 403 Forbidden message.
    I've tried changing file and directory permissions, although I think that there's nothing wrong with them, because everything worked fine before.
    Has anyone any idea what could be wrong?

    Great thanks, in advance!

    PS I'm using Fedora Core 5

    partial listing of apache document root:
    lrwxrwxrwx 1 root root 15 Oct 25 14:17 pub -> /var/samba/pub/

    [root@eros html]# cd /var/samba/
    [root@eros samba]# ls -l
    total 16
    drwxr-xr-t 6 nobody nobody 4096 Nov 5 23:04 pub
    drwxr-xr-t 2 nobody nobody 4096 Oct 26 19:46 tmp

    permissions of samba directory in /var:
    drwxr-xr-x 4 root root 4096 Nov 24 11:19 samba

    permissions of var in /:
    drwxr-xr-x 29 root root 4096 Nov 24 12:00 var

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,879
    So the system was working, and after a power-out, it isn't any more.

    Did you set the services to restart correctly in your current runlevel? Is the system running now? What happens if you run (as root) 'service smbd status'?
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Location
    Tallinn, Estonia
    Posts
    18
    Thank you for your answer.
    Actually after this power failure I realized that runlevels were not properly configured, but I started necessary services manually.
    Yes, the server is running now.

    The output of smb status:
    [root@eros ~]# service smb status
    smbd (pid 2114 2112) is running...
    nmbd (pid 2116) is running...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •