Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have redhat 9 and apache 1.3.29 installed. i compiled php4.3.4 as a DSO with apache. I also have the following lines in my httpd.conf file: LoadModule php4_module libexec/libphp4.so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370

    php on apache not working.


    Hi,

    I have redhat 9 and apache 1.3.29 installed.
    i compiled php4.3.4 as a DSO with apache. I also have the following lines in my httpd.conf file:
    LoadModule php4_module libexec/libphp4.so
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php3
    AddType application/php4script .php

    Also when i start up apache I get the following message in the log file:
    Apache/1.3.29 (Unix) PHP/4.3.4 configured -- resuming normal operations

    however when i try to access a php page thru the browser a "save as" dialog box opens instead of running the php file...i hv banged my head on this for over 2 hours now...can anyone pls help on this issue..

    thnks.
    Fixing Unix is better than working with Windows.
    http://nikhilk.homedns.org/projects/index.html

  2. #2
    Just Joined!
    Join Date
    Mar 2004
    Posts
    30
    http://www.php.net/manual/en/faq.bui...ld.not-running

    Look at number 10.

    Hope this helps.

    Richard

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Posts
    83

    Re: php on apache not working.

    Quote Originally Posted by nikhil
    Hi,

    I have redhat 9 and apache 1.3.29 installed.
    i compiled php4.3.4 as a DSO with apache. I also have the following lines in my httpd.conf file:
    LoadModule php4_module libexec/libphp4.so
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php3
    AddType application/php4script .php
    Hi nikhil,

    I noticed that you have the same mime type for .php and .php3

    I think it should be:
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php3 .php3

    Hope that helps.

  4. #4
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    thnks for the replies guys..i compiled php on apache1.3.9 and it works like a charm...i'll check to see the difference in the httpd.conf files between 1.3.29 and 1.3.9...i dont see AddModule sections for 1.3.29...i guess i did not
    compile it correctly.
    Fixing Unix is better than working with Windows.
    http://nikhilk.homedns.org/projects/index.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •