Find the answer to your Linux question:
Results 1 to 3 of 3
Hey guys, I'm trying to start httpd, but it fails every time. when I go to /etc/init.d and type httpd it tells me that the httpd.conf file is trying to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Question httpd issues...


    Hey guys, I'm trying to start httpd, but it fails every time.

    when I go to /etc/init.d and type httpd it tells me that the httpd.conf file is trying to load modules that it doesn't have installed...I've tried commenting the lines out, but then I have to go and edit more files because I commented those modules out...basically, I want to uninstall and reinstall httpd.

    problem....

    Code:
    [root@localhost init.d]# rpm -q httpd
    httpd-2.2.3-5
    [root@localhost init.d]# rpm -e httpd-2.2.3-5
    error: Failed dependencies:
            httpd-mmn = 20051115 is needed by (installed) mod_perl-2.0.2-6.1.i386
            httpd-mmn = 20051115 is needed by (installed) php-5.1.6-3.i386
            httpd-mmn = 20051115 is needed by (installed) mod_python-3.2.8-3.1.i386
            httpd-mmn = 20051115 is needed by (installed) mod_ssl-2.2.3-5.i386
            webserver is needed by (installed) webalizer-2.01_10-30.1.i386
            httpd >= 2.0.40 is needed by (installed) mod_python-3.2.8-3.1.i386
            httpd = 0:2.2.3-5 is needed by (installed) mod_ssl-2.2.3-5.i386
            httpd = 2.2.3-5 is needed by (installed) httpd-manual-2.2.3-5.i386
            httpd is needed by (installed) system-config-httpd-1.3.3-1.1.1.noarch
    How do I get around these dependencies?? is there a way to stop them so I can uninstall httpd and then restart them after it's installed???

  2. #2
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Location
    Pacific Northwest, USA
    Posts
    262
    Is it possible to use the distros package manager to install httpd? I assume since you are setting up a webserver it has web access right?
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  3. #3
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    109

    Thumbs up

    Using rpm -e http-2.2.3-5 --nodeps worked great.

    So I just reinstalled it and it works fine now. Thanks for everyones help!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •