Find the answer to your Linux question:
Results 1 to 4 of 4
Alright. I've troubleshooted most of it already. I just need a bit of a push. Ok here's my problem. No matter how I edit my webmin config settings, I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    34

    Webmin configuration help


    Alright. I've troubleshooted most of it already. I just need a bit of a push.

    Ok here's my problem. No matter how I edit my webmin config settings, I can never access webmin via browser. Here are the some of the steps I took.

    #1: Forwarded neccesary ports, and even used DMZ in my router to completely leave my computer unprotected.

    #2: Installed webmin correctly

    #3: Fooled around with config miniserv.conf

    I'm not getting anywhere and fast.

    The problem is, before this I installed XAMPP and could view the splash screen from http://localhost.

    I can no longer view that.

    The error I get is connection refused when trying to contact local host.

    It's not the router, and DSL linux does not come with a firewall.

    So I'm sure it has something to do with the configuration files of webmin.

    Because before webmin was installed, I could view the XAMPP splash screen.

    I looked in miniserv.conf and there were no Allow or deny lines, so I just left it.

    To access webmin I tried http://localhost:10000 and https://localhost:10000

    still didn't work. Connection refused.

    What I need to do is be able to access webmin from LAN which is about three computers.

    I can't understand what is wrong, and I've googled for hours and hours and CANNOT find a solution.

    hopefully you guys can help me.

    Otherwise i'll have to get rid of webmin

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    34
    Alright... I've got some things narrowed down.

    It's definetley the webmin configuration.

    I re installed DSL linux, and XAMPP, and webmin.

    I haven't touched any config files.

    The XAMPP splash page shows now at http://localhost, but webmin still won't show.

    I know it's not the router, as I have done extensive testing.

    It has to be the webmin config files. I just don't know what to edit.

    I've tried so many editing tips from other webmin config sites, but nothing works.

    Currently, the miniserv.conf has no allow= or deny= lines. Should I edit this file, or edit another file and leave this one alone.

    I'm so close I can taste it. Please help me out here.

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    23
    is your linux firewall blocking port 10000? this could be the problem, also make sure webmin is running.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    34
    Damn Small Linux doesn't have a firewall as far as I know.

    And yes webmin was running.

    I got rid of it now though. Just wasn't working out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •