Okey.

I've compiled apache2 and php5 (latest of both) from source, and installed the mysql 5 binaries, because I couldn't find the source (which is odd, maybe I didn't look hard enough).

I've got all the deps for the 3 things, and I've added mysql's bin to the $path, just in case.

I've compiled php --with-mysql-dir=/usr/local/mysql option, and I've got everything set up, BUT for some reason, php just refuses to recognise mysql.

Neither MySQL or MySQLi are coming up in the phpinfo, no matter what I do.

Every single thing I've read everywhere, suggests that for php5, which doesn't come with mysql libraries as we all know, compiling it with mysql does the trick....well I pose the question - wtf???


I would assume the mysql libraries for php aren't being loaded, well why? Where are they, and how do I load them into php?


Here's my full configure string:
'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql-dir=/usr/local/mysql/' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-memory-limit' '--enable-magic-quotes' '--enable-discard-path' '--enable-sockets' '--enable-track-vars' '--with-libxml-dir=/usr' '--with-xsl=/usr/local' '--with-zlib=/usr' '--with-mysqli-dir=/usr/local/mysql'


I have tried using mysql using terminal, and it works fine.
Other than that - php works fine.


But when I try to use mysql functions, it says they don't exist.


All of the scripts I've made previously which made use of mysql, come up blank. Note, I have set php to display all errors, and less complicated test scripts...like the one I just made work fine.

Trying a copy of phpbb3 (I always keep a few around), it cannot find support for any databases apart from sqlite, though it does work apart from that, so I'm sure php isn't broken, and I've recompiled it about 50 times when I've tried many things.


Weeeell, if anyone can suggest anything, please do


You should refer to this thread I made on the Ubuntu forums, to make sure you aren't double-suggesting the obvious.
http://www.ubuntuforums.org/showthread.php?t=320952
There seems to be no solution for this though, I'm stumped


Thanks!!