Find the answer to your Linux question:
Results 1 to 3 of 3
I am having a lot of trouble trying to get one particular machine to allow for a root login to samba. I have set Code: security = share and done ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    [SOLVED] Samba Rejecting User root !


    I am having a lot of trouble trying to get one particular machine to allow for a root login to samba. I have set
    Code:
    security = share
    and done
    Code:
    smbpasswd -a root
    and put in a password. I have also put in
    Code:
    valid users = root
    user = root
    under a share definition.

    However, when I try to log in as root with the password I put in to smbpasswd using smbclient I get the following
    Code:
    smbclient //hostname/sharename -U root%password
    tree connect failed: NT_STATUS_WRONG_PASSWORD
    and I also get the following error in my logs
    Code:
    Dec 25 20:07:35 hostname smbd[32023]: [2006/12/25 20:07:35, 0] passdb/pampass.c:smb_pam_passcheck(827)
    Dec 25 20:07:35 hostname smbd[32023]:   smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User root !
    Dec 25 20:07:35 hostname PAM-warn[32023]: function=[pam_sm_authenticate] service=[samba] terminal=[samba] user=[root] ruser=[<unknown>] rhost=[mymachine.mydomain.com]
    I have done the same configuration on several other servers and they work, I can't think why this doesn't work.

    I have been googling all over the place but the answers I have found say that I need to put in an smbpasswd, but I have put in an smbpasswd!

    Any Ideas?

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try setting the "smb passwd file" option in smb.conf to something like /var/lib/samba/private/smbpasswd
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    I figured it out. The problem was it was a very old installation of samba where the default was to not encrypt passwords and I have to explicitly tell it to encrypt them, whereas in the modern versions this is the default and I omit it.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •