Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I am trying to install syslog-ng 2 on a Fedora Core 6 computer. I have the glib2-2.12.3-2.fc6 rpm package installed, but when I do a ./configure of syslog-ng, I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46

    Can't install syslog-ng 2


    Hi,

    I am trying to install syslog-ng 2 on a Fedora Core 6 computer.

    I have the glib2-2.12.3-2.fc6 rpm package installed, but when I do a ./configure of syslog-ng, I get the following:

    checking pkg-config is at least version 0.9.0... yes
    checking for GLIB... configure: error: Package requirements (glib-2.0) were not met:

    No package 'glib-2.0' found



    I even tried installing glib2 from source, but I get the same thing. Specifically, I installed glib-2.12.0.tar.bz2 from source with default path (did not change prefix or any other install dir).

    I tried pointing the GLIB_LIBS variable to /usr/local/lib/ but I still get the same problem.

    Does anyone have any ideas why this is? Am I using the wrong path? Or did I install the wrong package?

    If I choose to do a ./configure --enable-dynamic-linking will syslog-ng start properly, or will I simply get a glib2 error when I try to start syslog-ng?

    Thanks for your help.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46
    I installed glib2-devel and the problem is solved.

    It is funny that syslog-ng's website did not say to install the devel package. It even has a link to the non-devel package.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •