Hi all,

just wanted to let you know that I found a fix for a pretty old problem.

When trying to run the squid supplied with the cygwin distribution, mostly you get the following error:
$ squid -N
FATAL: setrlimit: RLIMIT_NOFILE: (24) Too many open files
Squid Cache (Version 2.4.STABLE7): Terminated abnormally.
CPU Usage: 0.100 seconds = 0.030 user + 0.070 sys
Maximum Resident Size: 16000 KB
Page faults with physical i/o: 1089
Aborted (core dumped)

Here is how you can work around this problem:
You cannot use the binary squid that comes with cygwin - you have to get the source package and compile it on your own with the following steps:
- do the normal ./configure [your options]
- after the ./configure executed ok, edit the file include/autoconf.h and find
the line starting with #define SQUID_MAXFD
- set the value after the SQUID_MAXFD to whatever your system supports as maximum filehandles (you´can find this out by typing ulimit -n)
- compile normally

afterwards your squid should run ok. The squid ./configure script is buggy - it
does not find out the correct value for the maximum filedescriptors.

Cheers, Sebastian

-------------------
Need to tunnel through restrictive HTTP proxies? Get HTTPTunnel at http://http-tunnel.sourceforge.net