Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I am running a Debian 3.1 server remotely and i have set up Bind9 successfully for my domains. But "dig mx hotmail.com" or "ping google" on my local ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5

    "dig" and "ping google" do not work when bind9 runs.. why?


    Hi all,

    I am running a Debian 3.1 server remotely and i have
    set up Bind9 successfully for my domains.

    But "dig mx hotmail.com" or "ping google" on my local server does not work. e.g.
    Code:
    xyz:~# ping google.com
    ping: unknown host google.com
    I cannot edit the resolv.conf file
    not even using resolvconf.. if i do it by hand
    it changes itself back to original..

    # vi /etc/resolv.conf (sym link to /etc/resolvconf/run/resolv.conf)
    Code:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    nameserver 206.251.228.22
    nameserver 209.216.206.167
    nameserver 206.251.228.24
    search org
    someone has suggested adding forwarders in my
    /etc/bind/named.conf.options and so i did.. bad
    with no luck (it just worked initially while my
    syntax was wrong and the bind server was broken
    .. so all works fine when bind9 is stopped)

    my config files follow
    Any help would be appreciated,
    Alex




    -----------------------------------------------------



    /etc/bind/named.conf.options:

    Code:
    options {
            directory "/var/cache/bind";
    
            forwarders {
                    206.251.228.22;
                    206.251.228.24;
                    209.216.206.167;
            };
            forward first;
            transfers-in 150;
            
            auth-nxdomain no;
    
            recursion no;
    };


    /etc/bind/named.conf:

    Code:
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
    	type hint;
    	file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
    	type master;
    	file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.255";
    };
    
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
    
    include "/etc/bind/named.conf.local";

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    i added:

    Code:
     //recursion no;
    allow-recursion { 127.0.0.1; };
    and it works perfect

    cheers,
    Alex

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •