Find the answer to your Linux question:
Results 1 to 3 of 3
If I use the command: Code: mount -t smbfs //Server/Server /mnt/server -o username=jbloggs,password=pword123 to mount a shared Win2K network drive local folder I can browse the contents fine, but I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    94

    How to access a mounted SMB folder with user permissions


    If I use the command:

    Code:
    mount -t smbfs //Server/Server /mnt/server -o username=jbloggs,password=pword123
    to mount a shared Win2K network drive local folder I can browse the contents fine, but I don't have write permissions without becoming root. Is there any command I can use to give a user full access to the mounted folder please?

    Any help much appreciated.

    EDIT: I have also tried changing the permissions of the folder "/mnt/server" but it just resets back to root ownership after I mount the drive

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    try
    Code:
    mount -t smbfs //Server/Server /mnt/server -o rw username=jbloggs,password=pword123
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    94
    I tried that but it just gave me a list of options. I tried adding a comma instead of a space between "rw" and "username" which successfully mounted the drive, which worked but didn't give the required access, I still was told I didn't have permission to write.

    I then followed the directions here which were a great help. I can now mount with write permissions by use of the "uid=jbloggs" switch. For some reason the "gid=users" option didn't work for me despite being a member of the users group, only the "uid" option works, but nevermind, it does what I want it to now.

    Also, I attempted to edit my /etc/fstab file to auto-mount the drive, but no luck. I succeeded in seeing a network drive under "disk information" in "sysinfo:/", but I couldn't access it regardless of any combination of permissions options.

    At least I can mount it manually with permissions now though, that's what I was aiming for.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •