Find the answer to your Linux question:
Results 1 to 10 of 10
Hi folks, Ubuntu-6.06-LAMP-server-amd64 Xfce4 desktop I have registered "satimis.com" with Godaddy.com and my server is now running on static IP. The domain is active parking on Godaddy.com and rechargeable. Please ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    How to make domain pointing to server


    Hi folks,

    Ubuntu-6.06-LAMP-server-amd64
    Xfce4 desktop

    I have registered "satimis.com" with Godaddy.com and my server is now running on static IP. The domain is active parking on Godaddy.com and rechargeable. Please advise how to make it pointing to my server.

    I visited "Total DNS Control" and "Total DNS Control and MX Records" pages on "Godaddy.com" and could not figure out how to change them.

    Contacted their Technical Support with a reply;
    Code:
    You are receiving a Go Daddy parked page since the domain satimis.com is 
    parked on our servers. In addition, the domain's A record is pointed at our parked     
    IP address. In order to point your domain to a different location you will need to 
    modify the A record and nameservers for your domain. Unfortunately we are 
    limited on the support we can provide for pointing your domain at your own 
    server.
    Please help. TIA.


    B.R.
    satimis

  2. #2
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Location
    Pacific Northwest, USA
    Posts
    262
    Setup a free account here.

    Then point your domain to the nameservers: ns1.afraid.org, ns2.afraid.org, ns3.afraid.org, and ns4.afraid.org

    Then go to "Domains" on the left and add a domain. Enter the name of the domain.

    After that, add an A record for the domain and another A record pointing to the same IP address but with the subdomain www

    If you have any questions, just ask
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    12
    If you own a NameServer.. Point it there

  4. #4
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi folks,

    Tks for your advice.

    At this jucture, I'm a little bid confused here about which IP address I have to replace the IP address under "Points To"

    I have 2 fixed IP provided by ISP
    1) WAN IP
    2) Virtual IP on the router.


    performed following tests
    1) if typing WAN IP on browser it popup requesting for "User Name" and Password. I contacted ISP understanding that it was the IP of their router.

    2) if typing "Virtual IP" the test homepage of the server displayed.

    Tks.

    B.R.
    satimis

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    12
    I will give you easy option...

    Ask your ISP to maintain your domain pointer (your domain name pointed to your IP Address) in their nameserver...

    In goDaddy point your your ISP's nameserver (In the nameserver Option... type your ISP's nameserver)

    VERY EASY!

  6. #6
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi azlinux,

    Tks for your advice.

    In goDaddy point your your ISP's nameserver (In the nameserver Option... type your ISP's nameserver)
    On godaddy.com website:-
    Total DNS Control Panel
    Code:
      	
    satimis.com
    
    Host	        Points To		    TTL		        Actions
    @ 	        192.168.0.10 		    3600		change/delete
    
    CNAMES (Aliases)
    Host		Points To		                        TTL	Actions
    www 		@ 				                3600    change/delete
    	
    mobilemail 	mobilemail-v01.prod.mesa1.secureserver.net 	3600	change/delete
    	
    pda 		mobilemail-v01.prod.mesa1.secureserver.net 	3600	change/delete
    	
    email 		email.secureserver.net 				3600	change/delete
    	
    mail 		pop.secureserver.net 				3600	change/delete
    	
    pop 		pop.secureserver.net 				3600	change/delete
    	
    smtp 		smtp.secureserver.net 				3600	change/delete
    	
    ftp 		@ 						3600	change/delete
    	
    webmail 	webmail.secureserver.net 			3600	change/delete
    	
    e 		email.secureserver.net 				3600	change/deleteTXT (Text)
    	
    
    MX (Mail Exchange)
    Priority	Host		Goes To			        TTL	Actions
    0 		@ 		smtp.secureserver.net 	        3600	change/delete
    	
    10 		@ 		mailstore1.secureserver.net 	3600	change/delete
    
    
    TXT (Text)
    Host		TXT Value		TTL			Actions
    There is no nameserver option there.

    I changed "Points To" on "A (host) to "192.168.0.10 replacing former IP address "68.178.232.100".

    Now I can ping "satimis.com" and "192.168.0.10" locally but "www.satimis.com" did not work. I was unable to ping them on another network. I used "network_tools,com" testing them.


    B.R.
    satimis

  7. #7
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Location
    Pacific Northwest, USA
    Posts
    262
    192.168.0.10 is considered a private IP address and can't be routed over the internet. Go to whatismyip.com figure out your ip address (public IP address) and use that one instead. Also add the same IP address for www, or you could use a cname but I don't know if godaddy suports those. To do a quick test, enter the IP address in a web browser you get from whatismyip.com and that should bring up your web server.

    EDIT: Just realised this:
    Your servers IP address is 192.168.0.10, which means you are on a private network with NAT. You need to go to your router control panel and set it up to forward port 80 to your server (192.168.0.10).
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  8. #8
    Just Joined!
    Join Date
    Jan 2007
    Posts
    12
    ADD THIS

    @ IN NS xx.xxxxx.xxx
    @ IN NS yy.yyyy.yyy

    replace xx.xxxxx.xxx and yy.yyyy.yyy with your nameservers or nameservers of your ISP...

  9. #9
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi yourname3232,

    Tks for your advice.

    192.168.0.10 is considered a private IP address and can't be routed over the internet. Go to whatismyip.com figure out your ip address (public IP address) and use that one instead. Also add the same IP address for www, or you could use a cname but I don't know if godaddy suports those. To do a quick test, enter the IP address in a web browser you get from whatismyip.com and that should bring up your web server.
    Problem solved.

    Yes, you are correct. The virtual IP "192.168.0.10" is not the fixed IP of the server as told by my ISP. I think it is the port forwarding to a virtual server. The WAN IP "220.232.213.178" is the fixed/static IP of the server. After editing the DNS Control Panel on godaddy.com pointing to "220.232.213.178", only "www.satimis.com" can browse the test homepage of the server. And after 24 hrs "satimis.com" also works. Tks.

    EDIT: Just realised this:
    Your servers IP address is 192.168.0.10, which means you are on a private network with NAT. You need to go to your router control panel and set it up to forward port 80 to your server (192.168.0.10).
    I'm not allowed to touch the router which was preset and supplied by ISP. I have to call ISP to release port 25 and 80 on 192.168.0.10.

    I'm thinking is there anyway to solely control the router not relying on ISP? Buy another router and put the ISP router aside?

    TIA


    B.R.
    satimis

  10. #10
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi azlinux,

    ADD THIS

    @ IN NS xx.xxxxx.xxx
    @ IN NS yy.yyyy.yyy

    replace xx.xxxxx.xxx and yy.yyyy.yyy with your nameservers or nameservers of your ISP...
    Sorry I don't follow. Where to add them?

    $ cat /etc/resolv.conf
    Code:
    nameserver 202.14.67.4
    nameserver 202.14.67.14
    lookup file bind
    They are ISP nameservers.

    Tks.


    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •