Find the answer to your Linux question:
Results 1 to 7 of 7
Everything in terms of viewing shares from both sides is completely find with samba, However every time i reboot i find i have to remount the shares, Which really isn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    Sydney, Australia
    Posts
    4

    Automount samba shares


    Everything in terms of viewing shares from both sides is completely find with samba, However every time i reboot i find i have to remount the shares, Which really isn't that time consuming but still an irritation. I'm using Mepis (Debian based) and have looked for a way to do this all over the place, tried about 3 different supposed methods to no avail.

    The mount is going into the folder /home/chris/mnt/chrid

    Linux username=Blah, Samba username=blah
    Shared computer called ChrisXP
    Share called D
    UID=1000
    GID=1000

    Anyone got suggestions?

  2. #2
    Just Joined!
    Join Date
    Apr 2004
    Posts
    52
    this is how i do it in my fstab
    Code:
    //serve/share /mount-point smbfs username=xxx,password=xxx,fmask=777,dmask=777 0 0

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Location
    Sydney, Australia
    Posts
    4
    for some reason or another whenever i edit my fstab and reboot the configuration changes back to what it was before...

    any bright ideas? i am root.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    52
    What editor are you using? Are you saving the file?

  6. #5
    Just Joined!
    Join Date
    Apr 2004
    Location
    Sydney, Australia
    Posts
    4
    ive used kate and vi. i dont know why its doing this. ive even tried logging in as root as the actual user and editing it, still to no avail.

  7. #6
    Just Joined!
    Join Date
    Apr 2004
    Location
    Sydney, Australia
    Posts
    4
    problem fixed. for some reason or another mepis didnt like me manually editing config files.. Bye bye to you.. I'm now running slackware and quite pleased with it, got samba up and running again and managed to automount the shares on start by editing /etc/fstab

    The only issue now is that Gnome decides that it wants to links to the shares on my desktop that are undeletable.

    Anyone know how to get rid of these? I don't want them cluttering up my space.

  8. #7
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    configure your gnome desktop.. you would find option to show/hide disk drives, mounted shares. etc


    hope this helps
    I\'m just a simple fisherman blessed with a lot of friends

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •