Find the answer to your Linux question:
Results 1 to 7 of 7
I'm considering installing a simple ftp server, to be able to remotely edit web sites that I host. I wonder what pros/cons each have? YAST shows me two possibilities 1) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie felipe1982's Avatar
    Join Date
    Oct 2006
    Posts
    164

    which FTP server daemon do you use?


    I'm considering installing a simple ftp server, to be able to remotely edit web sites that I host. I wonder what pros/cons each have?

    YAST shows me two possibilities
    1) vsftpd (258K installed size)
    2) pure-ftpd (472K installed size)

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I've used vsftpd for quite some time now and have not been disappointed at all.
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    28
    I use vsftp. Easy to use, also if you havent already done so, install webmin, a http user control panel, makes settings up vsftp a snap.

    Question though I setup a symbolic link from my /var/ftp/ folder to point to /var/www/html and that works, I see a folder when I login to ftp called html. When I try and access it though, I get permission denied. All the files in my /var/www/html and below are owned by root:root. How do I allow access to all the files in my html folder to the user ftp? Thanks!

  4. #4
    Linux Newbie felipe1982's Avatar
    Join Date
    Oct 2006
    Posts
    164

    I cannot connect to vsftpd from "the outside." need ideas

    I cannot connect to vsftpd from "the outside."

    I've read the articles: one two three four

    I have successfully setup vsftp on my host computer (via remote ssh login). Everything is 90%, except "outside access to FTP server"

    I can connect to my ftp server by first connecting to my machine remotely (via ssh) and typing ftp localhost. I have created a dummy user account with zero priviledges and a chrooted home dir. It can read and write to ONE directory only (and all sub-directories of it). Everything works this way.

    I have set up apache httpd and filezilla server in the past (during my windows days), and I understand opening ports in firewall(s), forwarding ports in router, et al. I have opened ports 20,21,22 on my router and forwarded them to my server (both TCP/UDP). SuSEFirewall: I have enabled "ssh" and "http" and manually added ports 20,21,22 both TCP and UDP.

    As soon as I try to connect from my "local" computer (laptop) to my "server" via Konqueror (for example) I says it can't find the server.

    I tried turning off suse firewall - nothing. I feel worried about trying DMZ in router's settings . . .

    I am fresh out of ideas guys. What have I missed?

    ps - "server" is about 1 hour drive away from "local laptop."

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    28
    Take a look at your vs ftp config. Here is mine. Also, make sure your firewall inst blocking this traffic, make sure port 21 is open for teh server.

    Code:
    ftp_username=ftp
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    anon_upload_enable=NO
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    anon_mkdir_write_enable=NO
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    idle_session_timeout=3600
    #
    # You may change the default value for timing out a data connection.
    data_connection_timeout=15
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #nopriv_user=ftpsecure
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    ftpd_banner=*** Welcome To Belvedere ***
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # You may specify an explicit list of local users to chroot() to their home
    chroot_local_user=YES
    # users to NOT chroot().
    #chroot_list_enable=YES
    # (default follows)
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #ls_recurse_enable=YES
    
    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES
    force_dot_files=NO
    #hide_file=
    anon_max_rate=0
    local_max_rate=0

  6. #6
    Linux Newbie felipe1982's Avatar
    Join Date
    Oct 2006
    Posts
    164
    I appreciate your reply, but I have already done most of that stuff already (read post above for details). I already forwarded ports 20,21 TCP/UDP in both firewall and router (see post above). The server works 100% locally typing: ftp localhost. I've tried disabling the firewall -- no dice. There is nothing wrong with my vsftpd.conf; it's totally fine: here is a copy to verify.
    Code:
    write_enable=YES
    dirmessage_enable=YES
    #nopriv_user=ftpsecure
    local_enable=YES
    chroot_local_user=YES
    anonymous_enable=NO
    anon_world_readable_only=YES
    syslog_enable=YES
    connect_from_port_20=YES
    pam_service_name=vsftpd
    listen=YES
    ssl_enable=NO
    pasv_min_port=5000
    pasv_max_port=5003
    userlist_enable=YES
    userlist_deny=NO

  7. #7
    Linux Newbie felipe1982's Avatar
    Join Date
    Oct 2006
    Posts
    164
    here's what I did:
    -- shut off suse firewall
    -- put my computer out on the DMZ from inside linksys router web config

    I know this isn't safe, but I did it for less than 60 seconds, and nothing bad happened.

    Apparently, nothing good happened either. Vsftpd does NOT respond to requests at port 21.

    I'm really racking my brain on this one dudes! Could you give a fellow a hand?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •