http://www.linuxforums.org/forum/ser...in-domain.html

I was trying to followe the link below to do the installation :

I tried here : http://www.planetmy.com/blog/?p=248

I have installed all the required packages that have been mentioned, the only thing that I have not touch is Network Time Protocol.

[root@localhost ~]# cat /etc/krb5.conf
[logging]
default = FILE:/var/log/krb5libs.log
kdc = FILE:/var/log/krb5kdc.log
admin_server = FILE:/var/log/kadmind.log

[libdefaults]
ticket_lifetime = 24000
default_realm = rami.global
dns_lookup_realm = false
dns_lookup_kdc = false

[realms]
rami.global = {
kdc = 192.168.2.10
default_domain = 192.168.2.10
kdc = rami.global
}

[domain_realm]
.rami.global = rami.global
rami.global = rami.global

rami.global = rami.global
.rami.global = rami.global

[kdc]
profile = /var/kerberos/krb5kdc/kdc.conf
[kdc]
profile = /var/kerberos/krb5kdc/kdc.conf

[appdefaults]
pam = {
debug = false
ticket_lifetime = 36000
renew_lifetime = 36000
forwardable = true
krb4_convert = false
}
[root@localhost ~]#

















gedit /etc/smb.conf
!
!
!
[global]
# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
workgroup = rami
security = ads
realm = rami.global
client use spnego = no----------I added this line
server signing = auto
netbios name = linux
winbind use default domain = yes----------I added this line
winbind separator = +
encrypt passwords = yes----------I added this line
password server = rami.global
template shell = /bin/bash


[test]--------- ----------I added this Title

comment = Test Share using Active Directory
path = /data
valid users = @"rami\Users"
writeable = yes
browseable = yes
[root@localhost ~]#


[root@localhost ~]# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = MYGROUP
server string = Samba Server
log file = /var/log/samba/%m.log
max log size = 50
dns proxy = No
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /usr/spool/samba
printable = Yes
browseable = No
[root@localhost ~]#



[root@localhost ~]# service smb stop
Shutting down SMB services: [FAILED]
Shutting down NMB services: [FAILED]