The message is
What should Firefox do with this file? etc"

I am running SUSE 10.1 at home.
With Firefox I open http://localhost/myscript.html, which includes
<FORM METHOD="POST" ACTION="cgi-bin/myscript.cgi">

myscript.cgi is a Perl script, beginning with
#!/usr/bin/perl <-- path verified
read(STDIN,$temp,$ENV{'CONTENT_LENGTH'});
.... etc.

When POST in the html file is executed, I get:
"you have chosen to open myscript.cgi which is a CGI script from http://localhost
What should Firefox do with this file? etc"

When I put the same html and cgi files on a commercial server they work.

Do I not have CGI enabled in Apache?

/etc/apache2/default-server.conf contains this:

ScriptAlias /cgi-bin/ "/hdb/www/cgi-bin/"
<Directory "/hdb/www/cgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>

I would greatly appreciate any suggestions.
Peter