Find the answer to your Linux question:
Results 1 to 4 of 4
I've got a fresh install of Fedora 6 with LTSP- which has Apache 2.2.3 installed and up and running. I can use it- upload files and view them, etc. So ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5

    Can't find Apache directory!?


    I've got a fresh install of Fedora 6 with LTSP- which has Apache 2.2.3 installed and up and running. I can use it- upload files and view them, etc. So all was swell. I downloaded mod_dav to install, but when looking for apache directory (Normally /usr/local/apache(2) right?) I found it wasn't there. I've tried using kfind to search for anywhere else Apache might be, even trying different other names, but I've had no luck.

    Please, I have no idea where it is. Can anyone help me?

    I don't even know how to uninstall it. I can open yum because it wants to download stuff before running- which isn't possible here (dial-up shared with many others). I tried installing apache/httpd-2.2.4- but didn't get anywhere. It's updated, but I still don't know where it is!!

    Please help.

    Cheers in advance,

    JJ.

  2. #2
    Linux Newbie harner's Avatar
    Join Date
    Jun 2004
    Location
    PA, USA
    Posts
    209
    I don't know Fedora too well, did you try /var/www/apache? Did you even look it up in Google? Your package manager will usually tell you what files are installed and their respective locations.
    I praise Webmin and PuTTy!
    Registered Linux User: 439431

  3. #3
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Did you look in /var/www/htdocs? /usr/local/apache(2) is normally where apache is installed if you compile the packages from source. If you install using rpms, then the apache packages are scattered in various directories on your system.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5
    Okay, I uninstalled Apache, and installed apache-2.2.4 and it now shows up in /usr/local/apache2.
    Next problem, on trying to 'configure' mod_dav before installation (./configure --with-apache), it prompts me asking where the 'source' directory for apache is, and looking for SOURCEDIR/src/include/httpd.h.
    So I enter ./configure --with-apache=/usr/local/apache2, but /usr/local/apache2/src doesn't exist, but /usr/local/apache2/include/httpd.h does, so I thought to test it I'd change the /apache2 name to /src, and see what happened when i pointed it there- it then complained about not finding expat.
    Where am I supposed to point to or look to for the 'apache source directory?'
    And if I try ./configure --with-apxs=/usr/local/apache2/bin/apxs it complains that "APXS is broken."

    Please help.. I tried uninstalling expat (thinking that my k12ltsp F6 is putting it somewhere weird (as it was with apache) and installing it again, but that just resulted in losing my display mananger or desktop environment and still having no luck.

    Any ideas is greatly appreciated.

    Thanks.

    -JJ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •