Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I am running Squid 2.5.STABLE9 on Debian Sarge 3.1 but i am having problems with my delay pools. I have a connection of 100KB/s and i wanted to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    6

    Unhappy Squid Delay pool problem


    Hi,

    I am running Squid 2.5.STABLE9 on Debian Sarge 3.1 but i am having problems with my delay pools. I have a connection of 100KB/s and i wanted to use squid to slowdown downloads for avi, mpeg, mp3, etc and i also filter out porn sites.

    My current settings doesnt work... I went through so many sites about delay pools and i cant understand what is wrong... can anyone help me please.

    http_port 8080
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    cache_mem 48 MB
    cache_dir ufs /var/spool/squid 1000 2 256
    hosts_file /etc/hosts
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl our_networks src 10.0.0.0/24
    acl limitedfiles url_regex -i ftp .exe .EXE .mp3 .MP3 .vqf .tar.gz .gz .rpm .zip .rar .avi .AVI .mpeg .MPEG .mpe .MPE .mpg .MPG .qt .QT .ram .RAM .rm .RM .iso .ISO .raw .RAW .wav .WAV .mov .MOV .swf .SWF

    delay_pools 2

    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_access 1 allow our_networks
    delay_access 1 deny all

    delay_class 2 2
    delay_parameters 2 20000/20000 20000/20000
    delay_access 2 allow limitedfiles
    delay_access 2 deny all
    acl porn url_regex "/etc/squid/porn1"
    http_access deny porn all

    http_access allow our_networks
    http_access allow localhost
    http_access deny all

    http_reply_access allow all
    icp_access allow all
    coredump_dir /var/spool/squid

  2. #2
    Just Joined!
    Join Date
    Feb 2009
    Posts
    1

    Arrow Meaby be usefull chage the type acl

    Hi:

    first time i would like say that i'm learning to use squid and how to implemet delay pools on it, and next i would like say that my english is not good but i'll try to help


    you don say exactly what is wrong with squid, but i guess delay poools are not being aplied ?? I think it is 'cause squiid look for each delay pool rule and when it find a match then the search is stopped.

    See ur exaple:
    ----U have 2 ACL ()Acess Control List)----
    #This ACL is based on SOURCE
    acl our_networks src 10.0.0.0/24
    # And this on protocol (FTP) and part of URL
    acl limitedfiles url_regex -i ftp .exe .EXE .mp3 .MP3 ...

    --- And u have 2 delay pools---
    delay_parameters 1 -1/-1 -1/-1
    delay_parameters 20000/20000 20000/20000

    --- And finaly U grant acces to
    delay_access 1 allow our_networks
    delay_access 1 deny all

    delay_parameters 2 20000/20000 20000/20000
    delay_access 2 allow limitedfiles

    Squid begin looking for dellay rule and the firs rule is: delay zero to all local incoming request, i wan to say dely zero to all request that are from our_networt. What will happen if u change the delay pools order, first delay_access 2 allow limitedfiles
    and next delay_access 1 allow our_networks. Could be it fix the problem ?

    I hope that it coul be useful to u and i'm realy sorry by my poor english ..





    Quote Originally Posted by michaeljoser View Post
    Hi,

    I am running Squid 2.5.STABLE9 on Debian Sarge 3.1 but i am having problems with my delay pools. I have a connection of 100KB/s and i wanted to use squid to slowdown downloads for avi, mpeg, mp3, etc and i also filter out porn sites.

    My current settings doesnt work... I went through so many sites about delay pools and i cant understand what is wrong... can anyone help me please.

    http_port 8080
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    cache_mem 48 MB
    cache_dir ufs /var/spool/squid 1000 2 256
    hosts_file /etc/hosts
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl our_networks src 10.0.0.0/24
    acl limitedfiles url_regex -i ftp .exe .EXE .mp3 .MP3 .vqf .tar.gz .gz .rpm .zip .rar .avi .AVI .mpeg .MPEG .mpe .MPE .mpg .MPG .qt .QT .ram .RAM .rm .RM .iso .ISO .raw .RAW .wav .WAV .mov .MOV .swf .SWF

    delay_pools 2

    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_access 1 allow our_networks
    delay_access 1 deny all

    delay_class 2 2
    delay_parameters 2 20000/20000 20000/20000
    delay_access 2 allow limitedfiles
    delay_access 2 deny all
    acl porn url_regex "/etc/squid/porn1"
    http_access deny porn all

    http_access allow our_networks
    http_access allow localhost
    http_access deny all

    http_reply_access allow all
    icp_access allow all
    coredump_dir /var/spool/squid

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •