Find the answer to your Linux question:
Results 1 to 2 of 2
Hi folks, My first post here I'm total noob to linux and apache. My question is probably very basic apache conf related... I've searched and read several articles on this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! F@32's Avatar
    Join Date
    Jul 2006
    Location
    Cowjackingstan, Alpha-Centauri
    Posts
    3

    Question Apache2 on Mepis 6 via DynDNS and WRT54G


    Hi folks,

    My first post here I'm total noob to linux and apache. My question is probably very basic apache conf related... I've searched and read several articles on this subject, but most apache tutorials go like this: a. install apache, b...., c. configure MySQL, PHP5 and serve web pages

    1. I have installed apache2 on my single interface 192.168.1.3 laptop, running Mepis 6. I can see it's running because the welcome webpage comes on in browser when I type http://127.0.0.1 or http://193.168.1.3. I've replaced the default page in /var/www with my own and it shows up OK. I also have guarddog firewall running on it, but it looks like it has port 80 open.

    2. On the same LAN (255.255.255.0 subnet) I have another PC with 192.168.1.2 IP running WinXP. It can't see http://193.168.1.3 in browser, even though I can ping it OK. Do I need to change any apache2 settings to make server work on the LAN? Both 193.168.1.3 and 193.168.1.2 clients can get to internet.

    3. I set up DynDNS account and it synchronizes OK with my WRT54G v4. Before I forwarded port 80 to 193.168.1.3 if I typed my.dyndns.com in the browser I would get to router config web interface (meaning loopback works?). This tells me that dynamic IP works, but apache doesnt' respond for similar reasons as why I can't get to apache from my 192.168.1.2 PC. port-conf is listening to port 80, I can't conclude yet that my ISP is blocking outgoing traffic on port 80.

    Any help will be much appreciated.

  2. #2
    Just Joined! F@32's Avatar
    Join Date
    Jul 2006
    Location
    Cowjackingstan, Alpha-Centauri
    Posts
    3
    OK, I found the problem. Guarddog firewall was blocking outgoing http on port 80. Problem solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •