Hi!

I installed Fedora Core 6 including amavisd-new 2.4.4 and ClamAV
0.88.7. Everything worked fine, mails sent via postfix were checked by
ClamAV.
Since the ClamAV version is outdated, I updated to a newer version
0.90.1 as follows (using yum and atrpms repo):
<snip>
# yum update clamav
...
Running Transaction
Updating : clamav [1/7]warning: /etc/clamd.conf created as /etc/clamd.conf.rpmnew
Updating : clamav [1/7]warning: /etc/freshclam.conf created as /etc/freshclam.conf.rpmnew
Updating : clamav ###### [1/7]warning: /var/lib/clamav/daily.cvd saved as /var/lib/clamav/daily.cvd.rpmsave
Updating : clamav ######################## [1/7]warning: /var/lib/clamav/main.cvd saved as /var/lib/clamav/main.cvd.rpmsave
Updating : clamav ######################### [1/7]
Cleanup : clamav ######################### [2/7]
warning: /etc/sysconfig/freshclam saved as /etc/sysconfig/freshclam.rpmsave
Removing : clamav-update ######################### [3/7]
Removing : clamav-server-sysv ######################### [4/7]
Removing : clamav-server ######################### [5/7]
Removing : clamav-lib ######################### [6/7]
Removing : clamav-data ######################### [7/7]

Updated: clamav.i386 0:0.90.1-26.fc6.at
Complete!
</snip>
After the above I merged clamd.conf with clamd.conf.rpmnew and
freshclam.conf with freshclam.conf.rpmnew. Now I have only
/etc/clamd.conf and /etc/freshclam.conf

But now I have the problem, that the script clamd.amavisd which starts the
clamd for amavis doesn't run:
<snip>
/etc/init.d/clamd.amavisd: line 7: /usr/share/clamav/clamd-wrapper:
file or directory not found
</snip>
So the clamd doesn't start and mails are not checked:
Does anyone know how to fix the startup script and to reconnect
amavisd and ClamAV?