Find the answer to your Linux question:
Results 1 to 5 of 5
I am trying to install my printer on a server, and share it across the network through samba. Now, i have installed the printer ok, and the test print works ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790

    Printer server usiong samba


    I am trying to install my printer on a server, and share it across the network through samba. Now, i have installed the printer ok, and the test print works fine. Now, the problem i am having is installing it on my win XP box. i believe it is shared ok. Here is the smb.conf section for the printer and global:

    Code:
    [global]
            workgroup = HALFORD
            netbios name = WEBSERVER
            server string = Web server
            encrypt passwords = Yes
            map to guest = Bad User
            time server = Yes
            unix extensions = Yes
            socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
            printcap name = CUPS
            os level = 2
            local master = No
            domain master = No
            printing = cups
            veto files = /*.eml/*.nws/riched20.dll/*.{*}/
    
    [printer]
            comment = HP PSC 1205 Foomatic/hpijs (recommended)
            path = /var/tmp
            guest account = smb
            read only = No
            create mask = 0777
            guest ok = Yes
            hosts allow = 192.168.0.9
            hosts deny = ALL
            printable = Yes
            printer name = HP PSC 1205
            oplocks = No
    is there anything wrong here? When i try to connect to the printer (browse My Network places to the printer, right click it and click connect) it tells me:

    Code:
    The server for the printer does not have the correct printer driver installed.  If you want to search for the poroper driver, click OK.  Otherwise, click Cancel and contact your network administrator or original equipment manufacturer for the printer driver
    Anyone have any idea? I have tried searching the CD for a driver for this printer, and it's not on there, or it says there's no drivers for that model on the cd anyway! I'm stuck, and i want this working!!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Frederick, MD, USA
    Posts
    93

    Try installing the XP driver for the printer on XP.

    I had something similar happen with XP talking to XP. I had a printer installed on an XP Home machine. I had sharing turned on. I then went to another XP Home machine and tried to use the printer as you describe. I had the same result. I downloaded the XP driver on the second box and installed it. The next time I tried to print on the first machine it worked.

    Sorry for not discussing linux, but I think the problem lies with XP here. I have two linux boxes on my family network. I find that XP does not work well with linux or Windows 98. Linux works much better with 98 in my experience. I am using XP Home only and workgroup networking. I do not have an NT domain.

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I use both LM 10.0 and XP at home, and they play very nicely together. About your printer... Do you have the driver installed on the XP machine for it?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. #4
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Yes, i have the driver on my machine, and on the Linux machine. In order to get it working i had to download a ppd file from linuxprinting.org.

    bquark, you say you had this problem, did u manage to get round it? If so, how?!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  5. #5
    Just Joined!
    Join Date
    May 2004
    Location
    Frederick, MD, USA
    Posts
    93

    My problem was solved by installing driver on XP

    My problem was solved when I installed the Windows driver on the XP machine. It appears that even though there was a functioning driver on the machine with the printer, XP wanted to have the driver on the client machine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •