Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
Seems like sendmail is already running, which means port 25 is already used. Try stopping sendmail, then starting postfix....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649

    Seems like sendmail is already running, which means port 25 is already used. Try stopping sendmail, then starting postfix.

  2. #12
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi adrenaline,

    I got my problem fixed by running 'grep fatal /var/log/maillog'. It will indicate the source of mistake, simple and straightforward. Postfix is now running.

    One thing I could not resolve. I took >15 min. to fix the problem. Many long lines on /etc/postfix/main.cf were pushed to another line causing a break. Why they did not continue on another line?

    Anyway tks again for your support.


    B.R.
    satimis

  3. #13
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    Because of the editor you were using. In vim you need to do :set nowrap

  4. #14
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Hi likwid,

    Because of the editor you were using. In vim you need to do :set nowrap
    That is after pressing "i" and before typing started, type :nowrap [Enter] to turn word wrap on. Is there a way setting it permanent?

    satimis

  5. #15
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    No, this is before you hit i, when you're in command mode. To make it permanent you need to add set nowrap to your ~/.vimrc or /etc/vimrc.

  6. #16
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by likwid
    No, this is before you hit i, when you're in command mode. To make it permanent you need to add set nowrap to your ~/.vimrc or /etc/vimrc.
    Hi likwid,

    I got it done both as root and user. ".vimrc" did not exist. I created them with only one line on each files
    Code:
    set nowrap
    Tks

    B.R.
    satimis

  7. #17
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by likwid
    No, this is before you hit i, when you're in command mode. To make it permanent you need to add set nowrap to your ~/.vimrc or /etc/vimrc.

    Great tip.

    thanks
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  8. #18
    Just Joined!
    Join Date
    Mar 2010
    Posts
    4

    Cool

    Hi all

    six years later and guess what...i got a similar problem,

    I run postfix and dovecot, not sendmail (sendmail is not running i checked after reading this thread), the only errors in the log are as follows;

    Code:
    Mar 10 02:00:56 SYSTEMNAME postfix/postfix-script[6873]: stopping the Postfix mail system
    Mar 10 02:00:56 SYSTEMNAME postfix/postfix-script[6876]: waiting for the Postfix mail system to terminate
    Mar 10 02:00:57 SYSTEMNAME postfix/postfix-script[6879]: waiting for the Postfix mail system to terminate
    Mar 10 02:00:58 SYSTEMNAME postfix/postfix-script[6882]: waiting for the Postfix mail system to terminate
    Mar 10 02:00:59 SYSTEMNAME postfix/postfix-script[6885]: waiting for the Postfix mail system to terminate
    Mar 10 02:01:00 SYSTEMNAME postfix/postfix-script[6888]: waiting for the Postfix mail system to terminate
    Mar 10 02:01:01 SYSTEMNAME postfix/postfix-script[6890]: warning: stopping the Postfix mail system with force
    Mar 10 02:01:01 SYSTEMNAME postfix/postfix-script[6895]: fatal: the Postfix mail system is already running
    Mar 10 02:02:24 SYSTEMNAME postfix/postfix-script[6917]: stopping the Postfix mail system
    Mar 10 02:02:24 SYSTEMNAME postfix/postfix-script[6920]: waiting for the Postfix mail system to terminate
    Mar 10 02:02:25 SYSTEMNAME postfix/postfix-script[6923]: waiting for the Postfix mail system to terminate
    Mar 10 02:02:26 SYSTEMNAME postfix/postfix-script[6926]: waiting for the Postfix mail system to terminate
    Mar 10 02:02:27 SYSTEMNAME postfix/postfix-script[6929]: waiting for the Postfix mail system to terminate
    Mar 10 02:02:28 SYSTEMNAME postfix/postfix-script[6932]: waiting for the Postfix mail system to terminate
    Mar 10 02:02:29 SYSTEMNAME postfix/postfix-script[6934]: warning: stopping the Postfix mail system with force
    Anyone know why postfix wont STOP!

  9. #19
    Just Joined!
    Join Date
    Mar 2010
    Posts
    4
    why not lets all talk about nubs for a minute;
    [SOLVED]
    turned selinux off using setenforce 0 and postfixed finally stopped!

    (then re-enabled selinux with setenforce 1)

    bb for now

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •