Find the answer to your Linux question:
Results 1 to 4 of 4
here is the error when I try to re-start the service httpd httpd failed. The error was: Starting httpd: httpd: Syntax error on line 170 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_access.so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    9

    Question httpd problem and caused my httpd to shut-down


    here is the error when I try to re-start the service httpd



    httpd failed. The error was: Starting httpd: httpd: Syntax error on line 170 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_access.so into server: /etc/httpd/modules/mod_access.so: cannot open shared object file: No such file or directory
    [FAILED]


    I checked /etc/httpd/conf.d/modules
    and I do not see any file called mod_access.so

    was working fine for few hrs then I got this!!!!!!

    What can I do?

    I was ready to go online with my store.....and disaster happened... can't figure-out this problem

  2. #2
    Just Joined!
    Join Date
    Apr 2007
    Posts
    2
    Have you tried obtaining a copy of the Apache version you have, and extracting the related module?

    HTH


    Chris

  3. #3
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I ran into this before too. It most likely is a version issue, but I would try and comment it out and see what happens for now.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2007
    Posts
    4
    killall -9 httpd
    or

    killall -9 httpd_safe
    and after wrtie

    service httpd restart
    i think this fix problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •