Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 40 of 40
weird but he should check that out too. I haven't ran Suse since 7.2 so I am lacking in my Suse support lol...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058

    weird but he should check that out too. I haven't ran Suse since 7.2 so I am lacking in my Suse support lol
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  2. #32
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Quote Originally Posted by adrenaline
    I just thought of something else if you are using ~brett is the site in /home/brett ? If so you will need to change the document root in apache. (don't forget to create a backup of the file first)
    If the site is ....../~brett then apache (if it's still set up with its defaults) will look for a folder called public_html in /home/brett and publish the directory listing (or the contents of the file index.html if it exists). I don't think he needs to change the doc root to get that to work.

    But even if that's all screwed up, we'd still see a "Permission denied" or "404 Not Found", or some other error. The problem seems to be connecting to apache, which is why I still think the firewall issue is the most likely cause.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #33
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Agreed, good call.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  4. $spacer_open
    $spacer_close
  5. #34
    Just Joined! sunhaze's Avatar
    Join Date
    Dec 2006
    Posts
    16
    That sounds reasonable enough but im not running suse's firewall at the moment. Is there something running in the background i need turn off? Would it be apache or some other app.

  6. #35
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    I'd imagine the default state of the SuSE installation is that all ports are closed, and you need to open them one at a time. I'm not an expert at iptables, so I don't know the command to open port 80, but a bit of investigation may tell you how to do that.

    Or you could try switching on the SuSE firewall, and opening port 80. I use the SuSE firewall, and it's very easy to configure, so that would probably be the easiest thing to do.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  7. #36
    Just Joined! sunhaze's Avatar
    Join Date
    Dec 2006
    Posts
    16
    alrighty, opened up the firewall and allowd http server to go through, anything?

  8. #37
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    OK, So I am at home and it still isn't working

    Here is a helpfull hint

    netstat -an will tell you all the ports that are open on your linux box.

    No if you have an external firewall then that doesn't mean that port forwarding is enabled, but you will be able to tell it is open on your box.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  9. #38
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Quote Originally Posted by sunhaze
    alrighty, opened up the firewall and allowd http server to go through, anything?
    Nothing here either. Are you sure that the IP address hasn't changed? It *might* have changed if you rebooted the computer or the cable modem.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  10. #39
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    What happened with this, sunhaze? Did you ever get it working?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  11. #40
    Just Joined! sunhaze's Avatar
    Join Date
    Dec 2006
    Posts
    16
    not yet but as soon as summer gets here i will have some time to sit down and do it.

Page 4 of 4 FirstFirst 1 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •