Hi all,

first post! Hopefully someone can help me/

I have squid running as a proxy in parallel with Dansguardian which provides filtering. Thing is, because Dansguardian is located on the same box, all http requests now come from one source, ie localhost.

Therefore, all my acl's have been negated! To work around this, I rebuilt squid with the follow_x_forwarded_for option enabled.
Making the following changes to my squid.conf file :-

follow_x_forwarded_for allow all
acl_uses_indirect_client on
log_uses_indirect_client on


I expected to have the originating clients IP address be placed back into the header, to allow the acl's to reapply. However, no luck as yet! The access.log still shows all accesses from localhost.

Has anybody any experience with this in the past? Any help would be appreciated!!

Best Regards,
Brian