Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    transparent proxy using squid2.6-STABLE12

    squid_port: 3128

    in squid.conf i add the following two lines

    http_port transparent
    always_direct allow all

    but still transparent proxy doesnt work

    on squid server I got the following error,
    # squid -NCd1
    2007/04/16 10:43:54| Accepting proxy HTTP connections at, port 3128, FD 11.
    2007/04/16 10:43:54| commBind: Cannot bind socket FD 12 to (98 ) Address already in use

    when any client try to browse, then
    #squid -NCd1
    2007/04/16 18:21:21| clientReadRequest: FD 10 ( Invalid Request

    # tail -f /usr/local/squid/var/logs/access.log
    1176729681.883 0 TCP_DENIED/400 1965 GET error:invalid-request - NONE/- text/html

    If i configure the proxy setting, on the browser, I can then easily browse, but I cant config the all the browsers, as a proxy client... I need transparent proxy.

    plz help me config transparent proxy using squid2.6-STABLE12


  2. #2

    Thumbs up

    issue resolved

    my mistak was that I add "http_port" lines two times, one to define the the squid port, and second to define the transparent proxy... its the mistake.
    i was doing, in squid.conf
    http_port 3128 ### to define the squid listening port
    http_port 3128 transparent ### to config the transparent proxy

    I simply remove the "http_port 3128"... and issue resolved.. no eror, and transparent is working quite fine


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts