Find the answer to your Linux question:
Results 1 to 9 of 9
Greetings, I'm running Linux Fedora Core 2 with Samba 3.0.3-5 installed. It is connected to a LAN which has 2 Win98SE and 1 Win2k boxes. From the command prompt, "smbclient ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    7

    Samba: Can't Access Win2000 Shares from Linux


    Greetings,

    I'm running Linux Fedora Core 2 with Samba 3.0.3-5 installed. It is connected to a LAN which has 2 Win98SE and 1 Win2k boxes.

    From the command prompt, "smbclient -L hostname -U username" works for all Win boxes; however, "smbmount" gives me: "5717: session setup failed: ERRDOS - ERRnoaccess (Access denied.) SMB connection failed" when I try to mount a file share on the Win2k box. "smbmount" works for the 2 Win98SE boxes. I can print from Linux to a shared printer on one of the Win98SE boxes.

    In Gnome, when I click Computer->Network->Windows Network->Workgroup I can see the Windows boxes on my network. When I click on the icon for the Win2k box, I get an error box that says "The folder contents could not be displayed. You do not have the permissions necessary to view the contents of the "Windows Network: ***"

    From all of the Windows boxes I can access the Linux box. I can access the Win2k box from the Win98SE boxes.

    Samba is configured to encrypt passwords, and "Guests" are authorized on the Win2k share.

    Does anyone know what's going on here?

    Thanks,

    GS

  2. #2
    Just Joined!
    Join Date
    Mar 2003
    Posts
    84
    well i'm not verry sure about this but i guess the problem is that you should creat the same user on the win2k machine so that it will be granted access, caus that's what the error msg means
    hope i helped

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    3
    How u configured the samba
    is as a share or security......


    Let me know abt that............

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    May 2004
    Location
    Chennai, India
    Posts
    116
    try

    Code:
     
    mount.smb //win2kbox/share /mnt/mountpoint -o username=winuser
    Provide: password for winuser when prompted.

  6. #5
    Just Joined!
    Join Date
    May 2004
    Posts
    7

    More Samba weirdness

    Thanks for all the comments. I'm running at "user" level security.

    Last night, I changed some parameters in my samba config file, and ran "smbpasswd -a username" for each user. When I went to bed last night, smbmount (and mount.smb) were working for both the Win98SE and Win2k boxes. Once mounted, I could browse the share in Nautilus, open, drag-and-drop, etc. Still had the problem with the "Network" window in Gnome, but I thought that I had made progress.

    This morning, I rebooted, and when I tried smbmount (mount.smb) everything seemed to work (no error messages). Then when I tried to access the mountpoint - via Nautilus or by doing "ls" in a terminal - the system froze. If I try smbumount I get "Device or resource busy." I have to use "umount -l" to unmount the share.

    What's weird is that the behavour is very erratic. If I start and stop nmb and smb a few times, and change some changes with SWAT, and then try again, then smbmount works fine. Once I reboot, it all starts again.

    Here are the results of testparm:

    # Global parameters
    [global]
    workgroup = UCHI
    server string = %L running samba %v
    username map = /etc/samba/smbusers.map
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    ldap ssl = no
    idmap uid = 16777216-33554431
    idmap gid = 16777216-33554431

    [homes]
    comment = home on neronga
    path = %H
    valid users = %S
    read only = No
    hide special files = Yes
    hide unreadable = Yes
    hide unwriteable files = Yes
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [files]
    comment = network files on neronga
    path = /export/samba/files
    read only = No
    guest ok = Yes

  7. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    I have exaclty the same problem!!!

    I can mount shares using the mount command and I can see all the servers and shares using smbclient -L servername.
    All this works

    Once i have mounted the shre using "mount" I can also brows using nautilus.

    But when i try to brows the network things go wrong. I can see the workgroup and all the pc in it (DCD and all) its a wk2 ads domain by the way.

    When I try to access a single pc i get this: You do not have the permissions necessary to view the contents of "Windows Network: ghost". and thats it.

    I can access the shares on my own linux box using smb:// but thats where it ends.

    I am running fedora core 2 and have a windows 2k AD domain running. It worked fine with my old Fedora core 1 box.

    Please any body help.

    Here is my smb.conf

    # Global parameters
    [global]
    workgroup = TESTFR
    realm = ADSERVER.TESTFR.NET
    server string = Fedora Core 2
    security = DOMAIN
    auth methods = guest, sam, winbind
    password server = 10.10.10.1:389
    guest account = carl
    log file = /var/log/samba/%m.log
    max log size = 50
    time server = Yes
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    wins server = 10.10.10.1
    ldap ssl = no
    idmap uid = 16777216-33554431
    idmap gid = 16777216-33554431
    winbind use default domain = Yes
    winbind trusted domains only = Yes
    guest ok = Yes

    [homes]
    comment = Home Directories
    read only = No
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [download]
    comment = Meine Downloads
    path = /home/carl/download

  8. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    7

    I think ths is a bug in Fedora Core 2

    Hi Butler,

    I reported this to bugzilla here:

    https://bugzilla.redhat.com/bugzilla....cgi?id=125201

    And apparently, two other reports describing the same problem have been filed:

    https://bugzilla.redhat.com/bugzilla....cgi?id=123899

    https://bugzilla.redhat.com/bugzilla....cgi?id=125336

    I think you should add your observations, as a comment, to one of the above bug reports. The fact that it worked under FC1 is significant.

    ~ GS

  9. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    Bugzilla

    Hi,

    Have added a comment to the Bug posted in bugzilla.

    Have noted that it seems to only be aproblem with browsing available shares on the w2k PC

    Do you have the same problem or is this just me maiking slow progress.

    Browsing the share directly via nautilus using smb://server/share works fine.

    Butter

  10. #9
    Just Joined!
    Join Date
    May 2004
    Posts
    7

    Problem with Win2k, No Problem with Win98SE

    Yes, I am having the same problems. The problem only appears when I try to browse the shares on a Win2K box. It works fine for the Win98SE machines.

    Using smb://server/share is probably the best workaround (for accessing the shares) until this gets fixed. To browse the shares on a Win2k machine, use smbclient -L server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •