Find the answer to your Linux question:
Results 1 to 5 of 5
Hey, I'm no linux guru... But i know my basic stuff... I'm new to this site, so hello to all Anyways, I have lots of troubles getting this linux server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Banned
    Join Date
    Jun 2007
    Posts
    4

    Question You do not have permission to access the network resource


    Hey, I'm no linux guru... But i know my basic stuff... I'm new to this site, so hello to all Anyways, I have lots of troubles getting this linux server working, the samba problem being one of them. I'm basically setting up a web server, host name is "LiveServer" - I have a development server (running windowz) as well... Well, right now the dev server is the live server untill I get LiveServer up and running...

    I've searched and found 3 seperate samba tutorials, followed each one step by step, and I still have this problem.

    When I try to access the samba share I created (for the htdocs folder) from windows, it says "\\LiveServer is not accessible. You may not have permission to access the network resource. Please con....blablabla". Now, I've made sure the folder is browse-able, and available, and not read only etc. I added the users root and kthxbai2u to the userlist for the share. All the samba services are running, and the server even shows in My Network Places on my XP box. When i double click it to list the shares, it pops that message up. When i type in "\\LiveServer\htdocs" it says the same thing.

    What's going on? I had samba working on FC5, but FC5 doesnt run fast on my linux box, but suse does... Im using suse now. Any idea as to whats happening? Why does it say this when ive added users to the shares and set the samba password for root and kthxbai2u?

    Oh, one thing i left out, i set the authentication to user.... Anything else you neeed to know jus lemme know and ill let you know :P

    thanks for your help greatly appreciated

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    94
    Firstly, welcome to the forums!

    I too have been having major problems using SAMBA under SuSE. The ONLY way I have manged to get a connection from either a Windoze or Linux box is to set the share as public. Any other configuration results in a password box appearing and, despite my entering a good password, it just won't accept it.

    I have tried more tutorials and walkthroughs than I can count at this point. I have scoured the forums. I have installed and re-installed openSuSE10.1, openSuSE10.2 and SLED10 and still no joy. I have turned off all security measures including the firewall, but if that public box isn't ticked, no connection.

    What I have managed to find out is that the server constantly thinks I am "nobody". <insert jokes and witty retorts here> It seems my battle is convincing the server that I am an authentic user, and not "nobody".

    I'd love to hear from anyone that might have a suggestion. If I have a breakthrough I'll post it here, but until then, good luck!

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Auckland, New Zealand
    Posts
    14
    If you have the authentication set to 'user' you'll need to log onto your Windows machine using a username and password. This needs to be the same username password you added to Samba's password file. The same user has to have permissions to read or write the files in the Samba share.

    Once you've got your Samba installation working, it just works!

    You could try posting your smb.cnf file that should be located under etc/samba

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    94
    Quote Originally Posted by gavinj View Post
    If you have the authentication set to 'user' you'll need to log onto your Windows machine using a username and password. This needs to be the same username password you added to Samba's password file.
    Well this could be part of my problem, since I have never added any passwords to any files. I have set up users for the Linux box itself with exactly the same username/passwords as the Windows boxes and thought samba would authenticate against that. So where do I add the password please?

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    94
    I eventually sorted this. I opened a terminal as root and used the command:
    Code:
    smbpasswd -a [username]
    I have now wound the security down tightly and have a fully functioning network server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •