Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I just installed W.A.M.P. and everything is working great with the exception of one thing. The problem is that I created a virtual host for my domain name but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98

    403 Forbidden error


    Hi, I just installed W.A.M.P. and everything is working great with the exception of one thing. The problem is that I created a virtual host for my domain name but every since I did that, I get an error message when I try to browse my website. Here is the error that the browser displays:
    Code:
    Forbidden
    
    You don't have permission to access / on this server.
    What could be cousing this error and how could I fix it?
    Thanks for the help!

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    That could be a permissions issue, trying doing "chmod 755" on the directory containing the web files for your virtual host.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    Thank you for the reply!
    I figured out what was causing the error. I didn't specify any permissions for my virtual host directory, so no one could access my website. To specify the right permissions, I had to add something like this to my virtual host conf file.
    Code:
    <Directory "/path/to/my/website/directory">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    After I added this to my virutal host conf file, everything worked just fine.

  4. #4
    Banned
    Join Date
    Jun 2007
    Posts
    3
    Thank you for help

  5. #5
    Just Joined!
    Join Date
    Jun 2007
    Posts
    1

    help

    I tried the same but still got the error.Should i post the httpd.conf file so that u can check whether the permissions are set right or not.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •