Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I have a problem in squid with a particular website. I'm trying to cache images but squid doesn't work where the cache of browser works properly. This is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3

    Squid: always TCP_MISS but cached on browser


    Hi all,
    I have a problem in squid with a particular website.
    I'm trying to cache images but squid doesn't work where the cache of browser works properly.

    This is from access.log
    Code:
    1182245871.667    674 squid_ip TCP_MISS/200 45750 GET http://squid_ip/WebImage.aspx?file=ecc16d83-d9f1-4685-96bb-c075fd91f061&x=4&y=20&level=4 - DEFAULT_PARENT/remote_ip image/jpeg
    This is from the browser (about:Cache):
    Code:
    key:	http://squid_ip/WebImage.aspx?file=ecc16d83-d9f1-4685-96bb-c075fd91f061&x=4&y=20&level=4
    
    fetch count: 4
    last fetched:2007-06-19 10:39:38
    last modified:2007-06-19 10:39:24
    expires:1970-01-01 01:00:00
    Data size:45423
    file on disk: /home/carlo/.mozilla/firefox/7vnatso6.default/Cache/EB181604d01
    Security:This document does not have any security info associated with it.
    Client:HTTP
    request-method:GET
    response-head:HTTP/1.0 200 OK
    Date: Tue, 19 Jun 2007 09:49:11 GMT
    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET
    X-AspNet-Version: 1.1.4322
    Cache-Control: private
    Content-Type: image/jpeg
    Content-Length: 45423
    X-Cache: MISS from squid_ip
    Via: 1.0 squid_ip:80 (squid/2.6.STABLE13)
    Do you have any idea?

    Best regards

  2. #2
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3
    This is from store.log
    Code:
    1182273300.409 RELEASE -1 FFFFFFFF 16CE8098139FF24EE1337B595B1E8E7C  200 1182273888        -1        -1 image/jpeg 37996/37996 GET http://squid_ip/WebImage.aspx?file=ecc16d83-d9f1-4685-96bb-c075fd91f061&x=5&y=20&level=4
    I have always a RELEASE on squid but the browser cache the image so I can't understand why.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •