Find the answer to your Linux question:
Results 1 to 7 of 7
Hello there. I am experiencing some problems with vsftp. I have set up a vsftp server running through xinetd. All seems fine i can connect from a remote computer and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    London
    Posts
    6

    vsftp directory listing


    Hello there.
    I am experiencing some problems with vsftp.

    I have set up a vsftp server running through xinetd. All seems fine i can connect from a remote computer and i can see them connecting on the server. However, remote computers cannot issue a directory listing command successfully. they can cd and pwd around the directories on the server but cannot list the directory. this obviously means that they cannot connect successfully using a browser or ftp client.

    What can i do.

    Any help would be much appreciated.

    thanks

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Location
    London
    Posts
    6
    Could this have anything to do with data port access?
    Does port 20 need to be open?
    My nmap does not list port 20

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    40

    vsftpd

    Yes, port 20 must be open for the ls command to be able to return a list. Let me know if you still have problems.

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    London
    Posts
    6
    Excuse guys but I am a newbie

    How can i open ports in LInux? I found the following command on another forum but it gives me "bad argument '20' "

    iptables -I INPUT -p tcp -dport 20 -j ACCEPT

    thanks

  5. #5
    Just Joined!
    Join Date
    Jun 2004
    Posts
    40

    opening ports in linux

    you only have to set the firewall settings in linux, the easiest way to do this is to click on the redhat, go to system settings, click security level, and set the firewall settings. Open ftp and whatever else you want. Do not click on the trusted device control box because it will let all traffic in. Also, what kind of connection do you have? Is it DSL or Cable, or what? Do you hava a router? List all of your hardware. Good luck.

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Location
    London
    Posts
    6
    Thanks for you help.
    IT is getting rather frustrating. I have tried the 'no firewall' option and nothing changed, i tried combining this with turning the iptables off but no success there either.
    I have an ADSL connection I use a D-Link DSL-300T. I updated the firmware which according to D-Link means that there is no inbuilt firewall now.

  7. #7
    Just Joined!
    Join Date
    Jun 2004
    Posts
    40

    ftp

    I know what you are going through. It is because you have a pppoe connection with your adsl. Put your dsl modem in bridged mode through it's configuration tool by typing it's ip address in your web browser. Then, let your router handle the connection. Tell it your connection type, and provide it with your username and password. Email me if you have any problems. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •