Hello !

I have a problem with Bind9, i follow this tutorial which explain howto configure bind9 (sorry, this is in french) Cache DNS in order to set up a cache DNS server, have a look at this error:

Code:
/etc/init.d/bind9 stop
Stopping domain name service...: bindrndc: connection to remote host closed
This may indicate that the remote server is using an older version of
the command protocol, this host is not authorized to connect,
or the key is invalid.
 failed!
Look at the error in my syslog:

Code:
named[19065]: invalid command from 127.0.0.1#52903: bad auth
This is my file's setting /etc/bind/named.conf (auth information only):

Code:
/
include "/etc/bind/rndc.key";


controls {
inet 127.0.0.1 allow { any; } keys { "rndc-key"; };
};
File /etc/bind/rndc.key
Code:
key "rndc-key" {
        algorithm hmac-md5;
        secret "T50+3ecaN3BJVKi0+dbHIQ==";
};
File /etc/bind/rndc.conf:

Code:
options {
default-server 127.0.0.1;
default-key "rndc-key";
};

server localhost {
key "rndc-key";
};

include "/etc/bind/rndc.key";

Whats wrong !? Any idea about the problem!?

Thanks !
RedVivi