Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    amavis-new/spamassassin issue

    Over the past few weeks I have been playing with postfix, amavis-new and spamassassin on a Debian box. This box sits in front of a Microsoft Exchange 2003 server to help filter out the ridiculous amount of spam and additional unwanted e-mail. However, I have noticed that the spamassassin headers are not appearing in the e-mails my users receive. I know of the spamassassin directive to limit the amount of headers a user sees, but I also know that their is one header, the version header if I remember correctly, that the user will always see due to whatever reason. Even this header is absent from the e-mail headers. I am at a loss as to why this is occuring. I have told amavis-new to perform spam filtering by editing the /etc/amavis/conf.d/15-content_filter_mode with the following:

    # Default SPAM checking mode
    # Uncomment the two lines below to enable it back
    @bypass_spam_checks_maps = (
       \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);
    In addition to my puzzlement I see the following in the mail.log file when valid e-mail is either rejected or let through respectively:

    amavis[25967]: (25967-09) Blocked SPAM
    amavis[25730]: (25730-08) Passed CLEAN
    Is there something I'm missing? I was under the impression amavis-new was basically the glue for postfix and spamassassin to function as most people want them to function. As for one last reason why I suspect spamassassin is not functioning, my users still get a ridiculous amount of spam.

    On one last note my /etc/postfix/ file contains the following:

    # Amavis code from
    smtp      inet  n       -       n       -       20       smtpd
            -o smtpd_proxy_filter=
            -o smtpd_client_connection_count_limit=10
    #This is the after-filter smtpd, it receives mail from amavisd to port 10025    inet  n       -       n       -       -       smtpd
            -o smtpd_authorized_xforward_hosts=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o smtpd_data_restrictions=
            -o receive_override_options=no_unknown_recipient_checks

    Thanks for all the help.


  2. #2
    You need to check the following in your amavisd.conf.

    $sa_tag_level_deflt = 2.0;
    $sa_tag2_level_deflt = 5.0;
    $sa_kill_level_deflt = 6.31;
    $sa_dsn_cutoff_level = 10;
    $sa_quarantine_cutoff_level = 20;

    Most important is the $sa_tag2_level_deflt. This is the level that needs to be reached before your email subject gets rewritten. Also look take a look at the header of the email. You should see something like this:

    X-Spam-Flag: YES
    X-Spam-Score: 23.523
    X-Spam-Level: ***********************
    X-Spam-Status: Yes, score=23.523 tagged_above=2 required=5...

    So as you can see with this email, the header is changed when tagged above 2 and the subject is rewritten above 5.

    I hope this helps or give you some direction.

  3. #3
    Well it turns out apt-get for Debian installs the 2.42 version of amavis-new which uses some very odd configuration files. I removed that and installed 2.52 which actually uses the basic unix configuration file method, a simple .conf file. I played with that for a while and finally was able to get everything working. Thanks again for your help jsims.


  4. $spacer_open
  5. #4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts