Find the answer to your Linux question:
Results 1 to 8 of 8
Well, I'm totally new to this forum so I really hope someone over here can help me out. It seems that either my problem is not to be solved or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    Samba trouble


    Well, I'm totally new to this forum so I really hope someone over here can help me out. It seems that either my problem is not to be solved or just not interresting enough to explain on some other forums. Here I go again.

    My network setup:

    ADSL
    |
    |
    |
    ClarkConnect (router/gateway/server) box--------Linuxbox (Debian SID)
    |
    |
    WinXP box

    Networking is al fine; I installed samba on the debianbox and with SWAT I enabled shares and configured the network. One thing just wont work. I can't write to the debian box from either the clarkbox nor the winbox. I copied the configuration from the clarkbox using SWAT (I can write form winbox and debbox with no problem) but still it doesn't work.
    Googling did point me to a short post somewhere about debian never allowing the guest 'nobody' to write. This is the default so perhaps that's the problem (Clark is redhat based). Changing it to ftp (recommended somwhere) didn't help: it leaves me with an annoying login at the winbox.

    Any clues on how to fix this? At this point I just need my network to have write access to the shared folders on all boxes. I'll worry about not giving access to some users and how to do that later.....

    Regards

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Can you post your /etc/samba/smb.conf?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12
    I'll post the 2 configs (clark and debian) as soon as I'm home from work!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12
    right the configs:

    1. The clark config (redhat samba server)

    # Samba config file created using SWAT
    # from 0.0.0.0 (0.0.0.0)
    # Date: 2004/06/21 19:29:08

    # Global parameters
    [global]
    workgroup = OFFICE
    netbios name = CLARKCONNECT
    server string = ClarkConnect Office Edition
    interfaces = eth1
    bind interfaces only = Yes
    security = SHARE
    encrypt passwords = Yes
    max log size = 50
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    wins support = Yes
    use client driver = Yes

    [printers]
    path = /tmp
    printer admin = guest
    guest ok = Yes
    printable = Yes
    printing = cups
    print command = lpr -r -P%p -o raw %s
    browseable = No

    [homes]
    read only = No
    browseable = No

    [shared]
    comment = Publieke gedeelde map
    path = /home/shared
    read only = No
    guest ok = Yes

    [website]
    comment = Publieke Web-Server map
    path = /var/www
    read only = No
    create mask = 0755
    guest ok = Yes

    2. the debian samba config

    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2004/06/21 19:30:53

    # Global parameters
    [global]
    workgroup = OFFICE
    server string = %h server (Samba %v)
    security = SHARE
    obey pam restrictions = Yes
    passdb backend = tdbsam, guest
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    log file = /var/log/samba/log.%m
    max log size = 1000
    server signing = auto
    dns proxy = No
    ldap ssl = no
    panic action = /usr/share/samba/panic-action %d
    invalid users = root
    strict locking = No
    include = /etc/samba/dhcp.conf

    [homes]
    read only = No
    browseable = No

    [test]
    path = /home/test
    read only = No
    guest ok = Yes

    So the 'test' dir should be writeable but isn't neither from the clark box as form the XP box. The clark box itself can be writen from the deb box and the xp box. No clue what's wrong....

  6. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try this (in the deb box):

    Code:
    [test]
    path = /home/test
    valid users = guest
    write list = guest
    Edit: Don't forget to restart samba after changing the config.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you add the users to your smbpasswd file?

  8. #7
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12
    I haven't added any users...I read that the standard user is nobody and that one can write to the clarkbox so I guess it should be able to write to the debianbox. I also read somewhere that nobody on debian can never write and that I should use the user ftp instead. I'm not sure how to add the user. I did try changing nobody to ftp but I get a login at the xp box and can't login. Perhaps I should change it to ftp and add it to the smbpasswd? Guess my basics are still not good enough...

  9. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    78
    I created a user with the EXACT same login as the winxp box. Also the same password. After mapping my drives, it asked for the password once, and I never looked back. SMB works great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •