I've installed net-snmp and was sure this was working with SNMPv3 user authentication on Friday. Suddenly it does not seem to be working today.

I stop the snmpd daemon, then type the following:
Code:
net-snmp-config --create-snmpv3-user -ro -A mypassword -a SHA -X mypassword -x AES myuser
which adds a line to the end of /var/lib/net-snmp/snmpd.conf as follows:
Code:
createUser myuser SHA "mypassword" AES mypassword
I have also added the following line to /etc/snmp/snmpd.conf:
Code:
rouser myuser
then I start snmpd as follows:
Code:
snmpd -Lo -C -c /etc/snmp/snmpd.conf -f
the problem is that when trying to do an snmpwalk I get the following error:
Code:
snmpwalk -v 3 -u myuser -l authPriv -A mypassword -a SHA -X mypassword -x AES localhost
snmpwalk: Unknown user name
I notice in /var/lib/net-snmp/snmpd.conf that the line createuser is removed but no other lines are added, no usm line is added!

I've done all of this before last week and it worked, I don't understand why it's not working now. I wrote a script of my steps as I did this and verified that it worked, I am a bit confused as to what if anything I am missing.

I'm not sure if there is one or two problems here, because not only is snmpd swallowing the user, but when repeating the snmpwalk operation when the daemon was shut down I got exactly the same error.

Any ideas on this weirdness?