Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Dial-up modem works fine in root, but permission denied to ttyS0 when user tries

    Question about Vectorlinux - hope you don't mind, seeing as it's Slackware-based...

    I just reactivated an old dial-up account, and dusted down my very Linux-friendly serial Creative Modem Blaster.

    It dials up and connects perfectly for root, but when I log in as user, it shows me the finger and says permission denied to ttyS0 (or something very similar). I wondered if it was a file permission problem, so I logged in as root and gave /dev/ttyS0 read and write permission for everyone, but that didn't fix it.

    I stopped there, having thought that I'd better ask before causing any chaos!

    All ideas welcome... I'm sure it must be something easy, as it dials up so well as root. But I know the risk of surfing as root! Too scary.


  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    ls -l /dev/ttyS0 post output here

    I think you need to be in the dialout group
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3

    Dial-up modem root/user issue solved

    Thanks for your post Juan

    It is now solved, and exactly as you said - it's a group issue.

    Someone on another forum suggested I type this in root:

    usermod -G lp,floppy,audio,video,cdrom,games,scanner,users,tt y myusername

    (the tty doesn't have spaces, but in this forum there is a font display error which will not allow me to show these characters with no spaces when part of this string - very curious!)

    It worked perfectly...

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts