Find the answer to your Linux question:
Results 1 to 4 of 4
Currently running Slackware 10 on the notebook. APM/ACPI didn't work in 9.1 either. I tried both bare and bareacpi kernels on the Slack disks and neither worked. Some recommended I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    SW Florida
    Posts
    6

    Power Management on Thinkpad 600E


    Currently running Slackware 10 on the notebook. APM/ACPI didn't work in 9.1 either. I tried both bare and bareacpi kernels on the Slack disks and neither worked. Some recommended I upgrade to the 2.6.x kernel, so I was happy to see Slack10 came with the ability to install 2.6.7. However, I am having problems with that also! When I follow the instructions in the readme.initrd filed and I type the installpkg commands I get a file does not end in .tgz error. I am still very much new to Linux, so any help in the simpliest terms would be much appreciated. I have read countless articles and other links people give me, but it's just not sinking in.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    re: Power Management on Thinkpad 600E

    Hi jcambell, I'm also trying to get apm or acpi working on a 600e. I'm currently compiling various kernels and as soon as I have something figured out (if ever) I'll post back here. There are a lot of sites about the apm problems on thinkpads but none of the options that they say work have worked for me - yet.

    Can't help with the 2.6.7 kernel since I'm sticking with 2.4.x for now.
    --
    G.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    re: Power Management on Thinkpad 600E

    Well, I got my 600E working - I tried everything I could with apm and finally gave up and commented it back out in /etc/rc.d/rc.modules. I went with acpi instead and it's working great.

    This is for 2.4.x - it may not apply to 2.6.x.

    What I did:
    1.) Comment out the /sbin/modprobe apm line in /etc/rc.d/rc.modules
    2.) Install the bareacpi.i kernel from Slackware CD1
    3.) Added the line 'append="acpi=force pci=noacpi"' in the /etc/lilo.conf global section.
    4.) Ran 'lilo -v' to reinstall lilo
    5.) Installed acpid from Slackware CD1 a/ section.
    6.) Rebooted
    7.) Celebrated because it finally worked right
    --
    Hope this helps, G.S.

  4. #4
    Just Joined!
    Join Date
    Aug 2005
    Location
    Edgewater, FL
    Posts
    1
    Thanks gsinglet1 for the instructions I have got ACPI working on my 600E

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •