Find the answer to your Linux question:
Results 1 to 9 of 9
Hello all, I am new to these forums but I have had some experience with linux in the past from dual boot systems. I guess i should start with my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    15

    ok, long story but here goes.


    Hello all,

    I am new to these forums but I have had some experience with linux in the past from dual boot systems.

    I guess i should start with my specs.
    Hard drives: 1X maxtor 300 GB sata, 2X samsung 500 GB sata.
    DVD rw drive
    AMD 64 processor
    ASUS motherboard
    Floppy drive that i would rather not use (It has a piece of metal lodged in it that will be vey hard to get out.)
    OS: slax live cd, trying to install slackware.

    ok now I will start at the beginning, I started with my 300 GB hard drive with windows xp installed. I then decided to upgrade my hard drive by 1TB (2X500GB) but when i tried to install the new hard drives windows reinstalled itself and I lost the cd key for activation. I get on the phone to micrsoft and to make this part of the long story short they managed to make an enemy for life out of me. Now I am changing to linux and never looking back.

    So I download the slackware dvd from the slackware site and begin to install. At this point only one of my new hard drives is showing up with my old hard drive, but I decided to come back to that later (big mistake). So I installed slackware onto my new hard drive and lilo to my mbr (master boot record) and everything works great.

    At this point I have my windows hard drive as sda1, with all my files on it, and my linux hard drive as sdb1. Then out of nowhere my computer decides to register my second new hard drive and labels it as sda1, which makes my windows drive sdb1 and my linux drive sdc1. At this point slackware freaks out as it is trying to run linux from an NTFS hard drive. I reboot and get numerous error messages from linux and can't boot up.

    faced with this conundrum i decided to format my linux drive (now sdc1) and install slackware on my other new hard drive (now sda1) and put lilo on my mbr again. now when I start up I get the infamous "Disk boot failure, insert system disk and press enter" message just after bios.

    Ok so theres my problem. The only reasons I can think of that this might have happned are,

    1) something went wrong when i rewrote over my mbr or my motherboard is still looking for my mbr on sdb1 (I dont realy know what a mbr is or where it's installed). In either case I have no idea how to fix that.
    2) both of my current sda1 and sdb1 are marked bootable and this is confusing my motherboard. In this case would turning off the bootable flag on my sdb1 damage the data on it? or would I have to back-up my data on the sdc1 drive? because I would rather not do that. Also I don't think this is likely as I tried starting up my computer with my sdb1 drive disconnected.
    3) Lilo is still on the mbr of the first drive (now sdc1) and my motherboard has found two lilo's and is confused. I dont think this is likely either as my sdc1 drive is not marked as bootable.

    Well there's my problem, thanks for being patient enough to read through this and I hope I wasn't too confusing. Any help would be apricated.

    Thank you for you time.

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Well, let me see if I understood

    You have now three hard drives

    /dev/sda1 - Empty hard drive
    /dev/sdb1 - Windows and your files
    /dev/sdc1 - Slackware 12.0

    Right?

    Well, the BIOS will look for a bootloader installed on the first disk MBR, /dev/sda, you will need to install a bootloader there. I would suggest GRUB as I have more experience with it than LILO, make your Slackware partition the controller one and try to boot.

    If you can boot a live cd try and post the output of

    fdisk -l

    as root

    to get your layout correct
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    15
    yes i do have 3 hard drives but it goes in this order.

    /dev/sda1 slackware 12.0 (haven't managed to boot slackware from here yet)
    /dev/sdb1 windows and my files
    /dev/sdc1 empty hard drive

    when I installed slackware on sda1 I installed lilo to the same hard drive. sorry but I'm not sure what you meant by "make you slackware partition the controller one."

    here is the readout from fdisk -l.

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 60800 488375968+ 83 Linux
    /dev/sda2 60801 60801 8032+ 82 Linux swap

    Disk /dev/sdb: 251.0 GB, 251000193024 bytes
    255 heads, 63 sectors/track, 30515 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 30514 245103673+ 7 HPFS/NTFS

    Disk /dev/sdc: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 60801 488384001 83 Linux

    Thank you for your reply.

  4. #4
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    After powerup the BIOS kicks in.
    In what order does it seek boot devices? You can boot from the CD-ROM?

    'cuz that is what I think is strange, that Windows doesn't boot either.
    There is an incomplete install of Windows on your first disk? Can that not be a severe problem? How long have you been able to boot into Slackware? Or more precise how many times?
    Can't tell an OS by it's GUI

  5. #5
    Just Joined!
    Join Date
    Sep 2007
    Posts
    15
    Hi there,

    Thanks for your reply, you raised some interesting points.

    I set the boot priority to whichever option I need when I boot, (when I use slax live cd I set it to cd-rom and when I try to start up slackware I set it to Hard drive.) although I have only had the disk boot failure message when I boot from hard drive, slax runs with no problems whatsoever.

    I hadn't realized before but it is very strange that windows doesn't try to boot up. This leads me to belive that my problem may be that I have two hard disks set with a bootable flag. Although on the other hand I did have slackware working quite well before on an identical hard drive.

    I also think my problem might be on my mbr (master boot record) but I don't know exactly what this is or where it's stored. Is it on my motherboard? Is it on my hard drive? and if so will a format erase this? All the information I have found online regarding mbr's has been very technical and the only thing that looked like a how-to for formating a mbr seemed like a firmware job, which I dont feel very comfortable doing on my brand new terabyte.

    I have to go to sleep now but when I get a chance tomorrow I will move all my files from sdb1 to sdc1, then format sda1 and sdb1, set sda1 as the only bootable drive and then try a reinstall of slackware on sda1.

    Any input before I do that would be greatly appreciated as it sounds like a very big job which may lead to me losing some data and mightn't even work. Also any info on mbr's (either saying it here or through a link) in some kind of layman's terms Would at the very least put my mind at ease.

    Thank you again for your time.

  6. #6
    Linux Enthusiast
    Join Date
    Jul 2005
    Location
    Maryland
    Posts
    522
    Windows always wants to be on the first drive and on the first partition. So, try to switch drives around making NTFS drive first (sda) and see if windows is happy then.

  7. #7
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Sweating yet? I would.

    Some definitions before we get started:
    MBR
    Partitioning
    File systems
    Mounting
    cfdisk


    Here's the deal:

    You are gonna loose Windows
    Not because of technical issues, but due to legal issues. If you haven't got the CD key and you can't get their support it's useless trying anything.. unless you want to get into illegal hacking. Because yes, it is illegal to break in to your own operating system.

    With some care all your data can be retrieved
    Working from the Slax LifeCD you can mount all your hard drives. As you say yourself, copy all your files from one hard drive to another. Indeed, put it on the one drive that is not bootable: the sdc
    => If you have any questions about manual mounting, now is the time to look them up - or ask

    Repartition sda &sdb
    For simplicity just remove the Slackware install too. Others will say this isn't necessary and they are probably right. But removing Slackware gives you the chance of setting up some clever partitioning during Slackware's install later on. Remove all boot flags.
    => If you have any questions about manual partitioning or file systems, now is the time...


    Reinstall Slackware
    One of the first steps of the Slackware install is a prompt. You can run fdisk, cfdisk, setup and others. Run cfdisk.

    Suggested partitioning:
    Don't copy&paste, but think about it. You might come up with something more useful.
    Code:
    Set up the bootflag on sda
    Create a 10GB / partition (recommended = betewen 5 and 10 GB)
    Create a 5GB /dual partition (optional, but useful for dual booting in the future)
    Create a 1GB swap partition 
    Put the rest of your space under /home
    Now do a full install. Put lilo back in the MBR.

    Take special care not to let the installer touch your /dev/sdc. We have our own special plans for that drive. Your /dev/sdb can be formated and mounted under any location you see fit. And you can always change that afterwards.



    Now boot her up, et voila!


    ---
    Retrieving data:

    As root:
    Code:
    mkdir /data
    mount /dev/sdc /data
    startx
    You will find all your data in a directory called /data. Copy everything you want to keep. Erase the rest (or keep, for future reference)

    ---
    Loose ends:
    Your /dev/sdc doesn't get auto-mounted during boot. You have to manually mount it every time. This is because you took special care not to let the installer touch it.
    The reason for this is that I suspect /dev/sdc is either FAT or NTFS formated. Now that all your data is safely stored on another hard drive, you can change that. Then manually edit /etc/fstab to mount /dev/sdc during boot. This is not something to worry about now.

    If for some reason there isn't a writable filesystem on /dev/sdc, this whole procedure wont work. Device a clever workaround then, an post here when in doubt.

    It is very important that you check the contents of /dev/sdc before reformating /dev/sda and /dev/sdb. Make sure everything copied correctly and there weren't any unforeseen troubles.

    Good luck!
    Can't tell an OS by it's GUI

  8. #8
    Just Joined!
    Join Date
    Sep 2007
    Posts
    15
    Hi again,

    Thank you all for your help. I didn't get a chance to go near my computer yesterday but I've dedicated today to dealing with this.

    I understand the problem now. I should have known that my problem lay in that other os haunting me from beyond the grave. I knew that windows got touchy about being on the first partition but I didn't know that it had to be on the first partition of the first drive.

    I've decided to back up everything onto my sdc hard drive and format my windows drive, reclaim my hard disk space and be done with that os for good.

    My sdc hard drive is ext2 linux formatted so there shouldn't be a problem mounting it from the installer.

    I am in the middle of backing up my files and then I'm gonna start formatting and installing. I'll let you all know how it turns out.

  9. #9
    Just Joined!
    Join Date
    Sep 2007
    Posts
    15

    Sorted

    ok so I was very busy last week but every chance I got I worked on my computer. I formatted reinstalled an ungodly amount of times, with all sorts of different hard drive setups and playing a game of musical chairs with all my files. It eventually got to the point where I took out my 300Gb hard drive and one of my 500Gb hard drives and I was still getting an error. At this point I realized my problem had to be in my mbr, so I rolled up my sleeves and decided to get dirty.

    As it turns out, formatting an mbr isn't as scary as the instructions make it out to be. I formatted it with the dd command, reinstalled slack and everything booted up perfectly. I decided to erase the mbr's on my other hard drives just to be safe and have mounted both of them without any problems.

    I would like to thank you all very much for your help. I plan to check these forums regularly and try to help out as much as I can. I am starting a computer science degree this year and hopefully I will be able to dispense some of that knowledge here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •