Find the answer to your Linux question:
Results 1 to 2 of 2
I'm a rather new user to the Linux world, I have been using Ubuntu for a few months, and recently decided to try Slackware. Not wanting to commit to anything, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! classicalcraig's Avatar
    Join Date
    Oct 2007
    Posts
    6

    Mouse unresponsive under X


    I'm a rather new user to the Linux world, I have been using Ubuntu for a few months, and recently decided to try Slackware.

    Not wanting to commit to anything, I set up a virtual machine with MS Virtual Machine 2004 on my Windows PC to test Slackware 12.

    I did a full install, with xfce as the default window manager, as I liked the look of it from Xubuntu, and when I type startx, everything goes fine... until I try to use my mouse...

    I have tried to setup the mouse using mouseconfig and xorgconfig (advice I found on a previous thread) as a Generic PS/2, Microsoft PS/2 Intellimouse (the actual mouse I have) and even copying the settings from my Mandrake 9.1 xorg.conf file (also running under MS Virtual Machine). None of these approaches seems to work.

    I tested the mouse in KDE by booting to runlevel 4, but still no luck.

    I would appreciate any help offered, as googling for 'slackware configure mouse' and variants just brings up mouseconfig and xorgconfig

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    Kentucky
    Posts
    20
    Here is my relevant section for the mouse in Slack 12. I have a 3 button usb mouse. I made some manual edits. Everything that begins with # is termed as commented out, and will not be read by xorg.conf. This should work for you no matter what mouse you use.

    Section "InputDevice"

    # Identifier and driver
    # On platforms where PnP mouse detection is supported the following
    # protocol setting can be used when using a newer PnP mouse:
    # Option "Protocol" "Auto"
    # The available mouse protocols types that you can set below are:
    # Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
    # Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
    # MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
    # ThinkingMouse ThinkingMousePS/2 Xqueue
    # which is usually a symbolic link to the real device.
    # Option "Device" "/dev/ttyS0"
    # Option "Device" "/dev/ttyS1"
    # When using XQUEUE, comment out the above two lines, and uncomment
    # the following line.
    # Option "Protocol" "Xqueue"
    # Baudrate and SampleRate are only for some Logitech mice. In
    # almost every case these lines should be omitted.
    # Option "BaudRate" "9600"
    # Option "SampleRate" "150"
    # Emulate3Buttons is an option for 2-button Microsoft mice
    # Emulate3Timeout is the timeout in milliseconds (default is 50ms)
    # Option "Emulate3Buttons"
    # Option "Emulate3Timeout" "50"
    # ChordMiddle is an option for some 3-button Logitech mice
    # Option "ChordMiddle"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "Auto"
    Option "ZAxisMapping" "4 5"
    Option "Buttons" "5"
    # The mouse device. The device is normally set to /dev/mouse,
    Option "Device" "/dev/mouse"
    # Option "Device" "/dev/psaux"
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •