Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all , So while trying to switch to any of the tty from X, strange trace colors appear on the screen and then the terminal appear, but some times ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    problem switching to tty


    Hi all ,

    So while trying to switch to any of the tty from X, strange trace colors appear on the screen and then the terminal appear, but some times it stays like that and freeze ( I hate a lot the problems that appear some times ) .

    I believe the frame buffer isn't working properly appending vga=normal to the kernel eliminate the problem , so Slack 12 has Xorg 1.3 , i thought at the beginning this can be the problem , i tried some other distro comes with Xorg 1.3 no problem even having the most complicated splash screen of Fedora with vga=0x317 .

    So i would like if somebody knows what is the name of the package responsible of this (i'm sure it's in Xorg ) so i can try to update it.

    the problem also can appear while running xscreensaver (well also some times ) , i got really upset from this problem , my VGA is intel 945GM , i've update the xorg-driver-intel and the libX11 packages without any luck.

    So please HELP.

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like Graphics Card driver problem only. Which Video Driver are you using in xorg.conf file?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    intel.

    i've updated also the dri for intel and still the same problem.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I had a similar problem in a machine having SiS card. sis driver was creating problems and vesa driver sorted it out.
    Aren't you using i810 driver for Intel card? Have you tried 'vesa' driver?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I'm using intel driver , you know from xorg 1.3 to above the i810 is a symlink to intel_drv, for the vesa ,i'm not going to use it even if it can solve the problem , because it'll not allow me to go more than 800x640 . by the way this is a laptop , Acer aspire 5700, the one i got the windows refund of it , apart from this problem the laptop is working great, suspend/resume works .

    but this is a bit strange since the problem doesn't not exist at all in Ubunut 7.10 wish has xorg 1.3 , but only with my preferred OS Slackware 12.0 , by the way i'm using a generic Kernel in Slack .

    where the problem is coming from !!!

    VGA driver : i don't think since ubuntu and other disro uses intel Xorg drivers.
    Xorg itself , Slack 12 - 1.3 , Ubunut 7.10 - 1.3 , but okay i know options can be added/removed from Xorg while compiling !

    it's the first time in my life i'm having problem with Linux without being able to detect from where.

    Many thanks devil_casper for your interest in this . i hope we can find a solution soon .

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    IIRC, Ubuntu installs 915resolution by default now and it increases X Server performance. I dont know if its pre-installed in Slackware.
    Could you post the contents of xorg.conf file here?
    I will be glad to help you aliov. We will find its solution.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Code:
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "kbd"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xorg"
            Option          "XkbModel"      "pc105"
            Option          "XkbLayout"     "ch"
            Option          "XkbVariant"    "de_nodeadkeys"
    EndSection
    
    Section "InputDevice"
            Identifier      "Configured Mouse"
            Driver          "mouse"
            Option          "CorePointer"
            Option          "Device"                "/dev/input/mice"
            Option          "Protocol"              "ImPS/2"
            Option          "ZAxisMapping"          "4 5"
            Option          "Emulate3Buttons"       "true"
    EndSection
    
    Section "InputDevice"
            Identifier      "Synaptics Touchpad"
            Driver          "synaptics"
            Option          "SendCoreEvents"        "true"
            Option          "Device"                "/dev/psaux"
            Option          "Protocol"              "auto-dev"
            Option          "HorizEdgeScroll"       "0"
    EndSection
    
    Section "InputDevice"
            Driver          "wacom"
            Identifier      "stylus"
            Option          "Device"        "/dev/input/wacom"
            Option          "Type"          "stylus"
            Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
            Driver          "wacom"
            Identifier      "eraser"
            Option          "Device"        "/dev/input/wacom"
            Option          "Type"          "eraser"
            Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
            Driver          "wacom"
            Identifier      "cursor"
            Option          "Device"        "/dev/input/wacom"
            Option          "Type"          "cursor"
            Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
    EndSection
    
    Section "Device"
            Identifier      "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
            Driver          "intel"
            BusID           "PCI:0:2:0"
    EndSection
    
    Section "Monitor"
            Identifier      "Generic Monitor"
            Option          "DPMS"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Device          "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
            Monitor         "Generic Monitor"
            DefaultDepth    24
            SubSection "Display"
                    Modes           "1280x800"
            EndSubSection
    EndSection
    
    Section "ServerLayout"
            Identifier      "Default Layout"
            Screen          "Default Screen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
    Linux is not only an operating system, it's a philosophy.
    Archost.

  8. #8
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I think it's an internal slackware 12.0 problem , i tried slackware current and it seems everything is working well !
    Linux is not only an operating system, it's a philosophy.
    Archost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •