Find the answer to your Linux question:
Results 1 to 5 of 5
Frustrated, sleepy, Newb, so pls excuse my sloppyness. Fighting away with Ndiswrapper, installs fine, but I get problems when I get to modprobe. First is Module not found, even after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2

    Modprobe Error-Slackware12


    Frustrated, sleepy, Newb, so pls excuse my sloppyness.

    Fighting away with Ndiswrapper, installs fine, but I get problems when I get to modprobe.

    First is Module not found, even after depmod; because instead of the module going to "/lib/modules/2.6.15.5/misc" it ends up in "/lib/modules/2.6.15.5-smp/misc"

    I copy it over (I kno, bbut im only 36 hours into linux so i tried) and I get "invalid module format"

    after uninstalling I tried a make KERNERLPATH =/usr/src/2.6.15.5/ (slack installed both reg and smp kernel sources) still invalid format.

    freash install, made sure the smp source stayed out, still the module is created in the wrong directory.

    freash install, than tried to recompile the kernel to get all the pointers right, and my VAIO *****ed slapped me and went on strike.

    freash install again, tried this "ln -s /usr/src/linux-2.6.15.5 /lib/modules/2.6.15.5/build" and now "make ndiswrapper" returns errors like crazy.

    I called my geekiest friend, and he told me to get debian, I cursed him out, and need someone to help gain some self-respect. (I've been bragging how much I like slack) HELP!

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    35
    Did you get it figured out?

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    What is the output of:
    Code:
    uname -a
    Also, what is the output of:
    Code:
    ls -l /lib/modules/2.6.15.5
    and...
    Code:
    ls -l /usr/src
    Any way you can post it here? When you tried to "make" ndiswrapper, what are the exact errors you get? Can you post them here too? I think my Slackware 12 installed 'smp' as the default kernel and it's been working fine. Ndiswrapper compiled with no problems so I'm interested in seeing what is amiss with yours.

    By the way, Linux isn't like Windows where if something goes wrong you need to re-install. With Linux, you can hunt down the problem and fix it.

    Slackware is a really nice distro that will teach you a lot. My advice is to stay with it. If you DO get to that point where it seems too far over your head at this time, one of the *buntus are a really good choice for newer users...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2
    sry for going MIA like that, the holidays and all...

    the uname -a returns the kernel I'm running, 2.6.21.5 (sry for the typo before, I was tired)

    /lib/modules/2.6.21.5/ only listed the stock slackware files (no new folders)

    /usr/src/ only showed /linux-2.6.21.5/ (which I made sure of during Install #3)

    the kick in the ass was ndiswrapper was consistently installing to /lib/modules/2.6.21.5-smp/misc/ndiswrapper.ko

    I tried multiple times from multiple angles... It must be some problem with ndiswrapper, cause my system only had the 2.6.21.5 source to compile from, why it installed to the 2.6.21.5-smp modules is beyond me.

    I came to a solution from linuxpackages.net, where I got a ndiswrapper.tgz pack compiled for the 2.6.21.5 NON-smp. I used pkgtool to install, and was surfing the internet in 5 min!!!

    I know I shouldn't tack a new question to an existing thread, but it kinda relates.... What does SMP stand for??? "My" computer guy claims "Single Machine Processor" but I believe I read something like "Symmetric Multicore Processing"??? either way, my K6 550 sony Vaio wont load the install on 2.6.21.5smp, whenever I tried hugesmp.s my laptop would just reboot, so I was forced to use huge.s (2.6.21.5)

  6. #5
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Good you got it sorted!


    SMP stands for Symmetric MultiProcessing
    Can't tell an OS by it's GUI

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •