Find the answer to your Linux question:
Results 1 to 10 of 10
I have installed "Slackware 12" yet, but system can not mount automatically removable devices such as flash memories, floppy disks, CDs and DVDs. I always enter related data to "/etc/fstab" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    9

    automount problem


    I have installed "Slackware 12" yet, but system can not mount automatically removable devices such as flash memories, floppy disks, CDs and DVDs. I always enter related data to "/etc/fstab" file, then mount from terminal by "mount" command.

    I want Slackware to mount removable devices automaticaly. What can I do to solve this problem?

    *** I also added auto option to "/etc/fstab", but slackware recognizes my flash drive sometimes sda1 sometimes sdb1 and sometimes another.

  2. #2
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Welcome to the forum!

    Are you working from X? Are udev, dbus and HAL enabled and running?
    Have you put your user account in the proper groups?
    Did you put 'users' in the entry in /etc/fstab?



    As a note putting 'auto' in fstab means you want the device mounted at boot. This is normally not the case for removable media.
    Can't tell an OS by it's GUI

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    9
    Quote Originally Posted by Freston View Post
    Welcome to the forum!

    Are you working from X? Are udev, dbus and HAL enabled and running?
    Have you put your user account in the proper groups?
    Did you put 'users' in the entry in /etc/fstab?



    As a note putting 'auto' in fstab means you want the device mounted at boot. This is normally not the case for removable media.
    Thanks Freston.

    I am working on XFCE. I also put "users" option into /etc/fstab, this made any user to mount that drive. But now problem is different I have 2 two USB flash drives and 2 ntfs external USB hard drives. I added four lines into /etc/fstab for each drive. Now Slackware recognizes these drives but sometimes it says that "wrong file system in fstab!" then I reedit fstab file and then slackware mounts.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    9
    Are udev, dbus and HAL enabled and running?
    I could not understand this question I think I do not have enough knowledge to manage Linux yet.

  6. #5
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by malic
    But now problem is different I have 2 two USB flash drives and 2 ntfs external USB hard drives. I added four lines into /etc/fstab for each drive. Now Slackware recognizes these drives but sometimes it says that "wrong file system in fstab!" then I reedit fstab file and then slackware mounts.
    This is a numbering game really. If you plug in your ntfs external drive first, it'll be /dev/sda1, but if you plug in your flash drive first,then that is /dev/sda1... right?? The second one will be /dev/sdb1, etcetera.

    To correct my previous post a bit, you _can_ put 'auto' in fstab, in the file system section. That may help overcome this problem of wrong filesystem in fstab'.

    The quick route now is to put entries in fstab for sda1, sdb1 and whatever names get assigned to the drives. That's how I do it, because I like manual mounting. But most people prefer to let udev handle it.

    I don't know how Xfce handles these things, but KDE prompts you what to do with a detected device once you plug it in, if udev and such are enabled that is.

    Now I have to dig a little into memory if udev was running by default on SLackware, but I'm not sure.... is it running? You can check by:
    Code:
    ls /etc/rc.d
    Can't tell an OS by it's GUI

  7. #6
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    O sorry, didn't see you write this:
    Quote Originally Posted by malic
    I could not understand this question I think I do not have enough knowledge to manage Linux yet.
    I assumed from your opening post that you where familiar with these terms. You know, manual mounting and editing fstab aren't newbies games
    If you can do that, you'll have little trouble with the rest.


    Anyway, these are services that run on your machine to mount filesystems automagically. To see if they are running, see if they are executable:
    Code:
    ls /etc/rc.d
    Can't tell an OS by it's GUI

  8. #7
    Just Joined!
    Join Date
    Dec 2007
    Posts
    9
    Thank you very much Freston. Now I am not on my computer, I am at work on a windows machine. I will check those services by the help of "ls /etc/rc.d" at home. While installing Slackware, I was asked to enable some services suchh as CUPS and SAMBA. I probably ignored those services you mentioned about.

    During the installation I chose KDE as default. While system was operating on KDE after I plugged a flash drive, KDE asked me whether to open contents in a new window or not. Then answering "YES", system crashed and I edited "fstab" so that I mounted that drive from terminal.

    Does KDE's response to plugging any drive mean that these sevices are running?

  9. #8
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by malic
    Does KDE's response to plugging any drive mean that these sevices are running?
    Probably yes. But it's not supposed to crash :S


    If you find (some of) these services are not running, you can enable them by typing as root:
    Code:
    chmod +x /etc/rc.d/name_of_service
    /etc/rc.d/name_of_service start
    And/or

    Maybe you want to check out KwikDisk as a graphical front end for mounting. I don't know if it suits your needs, but you might want to take a look at it. I believe it comes with a default install of Slackware, in the systems menu.
    Can't tell an OS by it's GUI

  10. #9
    Just Joined!
    Join Date
    Dec 2007
    Posts
    9
    bash-3.1$ su
    Password:
    bash-3.1# ls /etc/rc.d

    init.d rc.dnsmasq rc.modules rc.sshd
    rc.0 rc.font.new rc.modules-2.6.21.5 rc.syslog
    rc.4 rc.gpm rc.modules-2.6.21.5-smp rc.sysvinit
    rc.6 rc.hald rc.mysqld rc.udev
    rc.K rc.hplip rc.nfsd rc.wireless
    rc.M rc.httpd rc.ntpd rc.wireless.conf
    rc.S rc.inet1 rc.pcmcia rc.yp
    rc.acpid rc.inet1.conf rc.rpc rc0.d
    rc.alsa rc.inet2 rc.samba rc1.d
    rc.atalk rc.inetd rc.saslauthd rc2.d
    rc.bind rc.ip_forward rc.scanluns rc3.d
    rc.bluetooth rc.keymap rc.sendmail rc4.d
    rc.bluetooth.conf rc.local rc.serial rc5.d
    rc.cups rc.messagebus rc.snmpd rc6.d

    bash-3.1# chmod +x /etc/rc.d/dbus
    chmod: cannot access `/etc/rc.d/dbus': No such file or directory
    bash-3.1# chmod +x /etc/rc.d/HALL
    chmod: cannot access `/etc/rc.d/HALL': No such file or directory
    bash-3.1# /etc/rc.d/dbus start
    bash: /etc/rc.d/dbus: No such file or directory
    bash-3.1# /etc/rc.d/HALL start
    bash: /etc/rc.d/HALL: No such file or directory
    bash-3.1#
    I tried this, then reinstalled slackware 12 . (I was already planning to resize partitions.)

    I activated some service I need. HAL service had been selected active as default.

    My problem was solved by adding "auto" option into file type column in /etc/fstab. Thank you very much.

    *** I could not understand why I could not activate services by "/etc/rc.d/dbus start" command.

  11. #10
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Quote Originally Posted by malic
    Code:
     bash-3.1# chmod +x /etc/rc.d/dbus
    chmod: cannot access `/etc/rc.d/dbus': No such file or directory
    bash-3.1# chmod +x /etc/rc.d/HALL
    chmod: cannot access `/etc/rc.d/HALL': No such file or directory
    bash-3.1# /etc/rc.d/dbus start
    bash: /etc/rc.d/dbus: No such file or directory
    bash-3.1# /etc/rc.d/HALL start
    bash: /etc/rc.d/HALL: No such file or directory
    bash-3.1#
    *** I could not understand why I could not activate services by "/etc/rc.d/dbus start" command.
    Oh! It's probably no longer necessary, but I thought I'd say one more thing about this. Why this didn't work, is because the name of the launch script for the service is preceded with 'rc.'
    So the proper command was: /etc/rc.d/rc.dbus start
    Also, it's case sensitive. HAL (Hardware Abstraction Layer) as an acronym I write capitalized, but the system knows it's launch script as /etc/rc.d/rc.hald , so in small letters. And the 'd' is for 'deamon'. Confusing? Yeah. Sorry about that
    To make it a little easier... these scripts are files in the /etc/rc.d directory. So you can find their full (correct) name with 'ls /etc/rc.d' and search through the output. I could have said that before and made your life easier

    To see which files are executable, there are three ways:
    1) Color coding. Executables are green
    2) The asterix (*) as a suffix to their name
    3) File permissions. the rwx-rwx-rwx sequence you get when you apply the '-l' flag to ls (ls -l /directory). 'x' stands for executable.

    I believe the Slackware root account doesn't have color coding enabled by default. You can add this line to /root/.bashrc if you like:
    Code:
    alias ls='ls --color=always'
    Can't tell an OS by it's GUI

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •