Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
I am a Windows user moving into the world of Linux, Slackware 12 to be exact. I have setup lots of different versions of Linux in the past without problem. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Location
    United States
    Posts
    8

    Can't access hard drive contents!


    I am a Windows user moving into the world of Linux, Slackware 12 to be exact. I have setup lots of different versions of Linux in the past without problem. My favorite is Slackware 11 but now in Slackware 12 I have ran into a problem I can't seem to figure out. I know this has to be something simple.

    When I try to access my hard drive I can't. What I mean is, the drive is unmounted and when I try to mount it I get an error message saying

    http://www.geocities.com/codefuror/snapshot1.png

    I have never seen this before out of all of the installs I have performed.

    Keep in mind, I can't access fstab because I can't access the drive, unless it can be done through the terminal window, which I'm sure it can be. I think I need to change permission's but I am unsure of how to do this through terminal window. I am still learning these types of techniques.

    It really don't make any since to me that I can't access the drive when I am logged in as root. I should be able to access everything as the root user, right?
    Anyway, Slackware 12 is the only operating system on my hard drive right now. I did have a dual boot with Slackware and Windows XP but I still had this same problem so I thought I would try Slackware only but I still have this problem. Any help on this matter would be great.

    Thanks in advance
    Codefuror

  2. #2
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    468
    You should be able to access /etc/fstab through a terminal window. Log in as root and use vi or kedit, whatever your favorite editor is. Post the contents here.
    Glenn
    Powered by Fedora

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You must be a member of plugdev Group. Add user in that group and you will have access to all disks.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2008
    Location
    United States
    Posts
    8

    I think I figured it out.

    As I suspected, access to everything in Slackware should have automatically been available as the root user. I installed Slackware 11 and everything works just fine. I have access to everything. So what I'm thinking is, either something happened in the download process or in the burning of the iso. So I'm going to re-download the image and try again.

    I know that I lost my internet connection due to a power outage during the download process so maybe it messed up the image. I'll let you guys know what the outcome is after I download and burn the image again. This time I'll burn a few copies at different speeds to see if that helps.

    Hey, thanks for the quick reply and suggestions guys. I'll post my results later today. Thanks again.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Nothing is wrong with download or installation media. You have to add user in plugdev group only. This is not default in Slackware 12.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined!
    Join Date
    Jan 2008
    Location
    United States
    Posts
    8

    Plugdev

    You were right devils_casper I downloaded, burnt and installed Slackware 12 with the same problem again. Man I must be a tard because I can't figure out how to access plugdev. Why would they change this? Is it for security reasons or something? Slack11 makes drives accessible through root automatically at least the hard drive is. I can't even access the hard drive to get to /etc/fstab because the drive is unmounted and I can't mount it because I don't have rights.

    I know one thing is for sure, don't become a windows user and then try to switch to linux. Windows is for lazy ppl. I'm in for the long journey though, I think Linux has a lot more to offer than Windows. I just need a little push in the right direction and then I'll catch on. If you could let me know how to access plugdev through terminal I would be most grateful, Thanks man.
    codefuror

  8. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by CODEFUROR View Post
    If you could let me know how to access plugdev through terminal I would be most grateful, Thanks man.
    codefuror
    I usually just edit the /etc/group file directly. Just go to a terminal, su to root, and enter the following command:

    Code:
    vim /etc/group
    Of course you substitute your favorite text editor for vim.
    oz

  9. #8
    Just Joined!
    Join Date
    Jan 2008
    Location
    United States
    Posts
    8

    No dice, man.

    OK I tried it but I still have the same problem, so I must have done something wrong, next to plugdev I added root and another one of my user names and hit Ctrl+x to save, then I rebooted and sill the same problem. Check this out, I created a different user and password and now I can access the windows partition and my USB flash drive, but when I try to mount hda2 drive (linux) it gives me a pop-up that reads "Permission Denied" Unbelievable man. and as ROOT I still can access nothing. It's silly man.

  10. #9
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1

    Me too!

    Quote Originally Posted by ozar View Post
    I usually just edit the /etc/group file directly. Just go to a terminal, su to root, and enter the following command:

    Code:
    vim /etc/group
    Of course you substitute your favorite text editor for vim.
    Hi, got the same problem as CODEFUROR. Can't access hd. Even edited the group file, only able to mount usb drive and dvd now. Well, that's an improvement. Still get the same error as CODEFUROR, "permission denied" when trying to mount hda1, my install drive and as for hda2, formated ext3, get message that it's a wrong file system type, bad option, bad superblock or missing code page. Don't know what to think. Guess I'll just follow along and see how this thread goes. Thanks for the help.

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Log in as root and execute id command. Does it list plugdev group too?
    Execute this to add Group
    Code:
    useradd -G plugdev root
    when I try to mount hda2 drive (linux) it gives me a pop-up that reads "Permission Denied" Unbelievable man. and as ROOT I still can access nothing. It's silly man.
    Regular users dont have access to mount command by default. Post the contents of /etc/fstab file and output of fdisk -l command here.
    Code:
    su -
    cat /etc/fstab
    fdisk -l
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •