Find the answer to your Linux question:
Results 1 to 9 of 9
i am trying to install things on my slackware server, but everytime I run "make" i get this message: make: *** No targets specified and no makefile found. Stop. i'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    Hello Forum, I have problems with "Make"


    i am trying to install things on my slackware server, but everytime I run "make" i get this message:

    make: *** No targets specified and no makefile found. Stop.

    i'm not sure but i think the problem may involve not having the c++ compiler, how can i check for it? and how do i install it?

    ps- i ran whereis g++ and got

    g++: /usr/bin/g++ /usr/man/man1/g++.1.gz /usr/share/man/man1/g++.1.gz

    thanx for any help.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums, propaganda!

    That means there is no makefile in the directory.

    What packages are you trying to install?

    You might be better off and have an easier time of it if you obtain Slackware packages and use pkgtool or installpkg to install them.
    oz

  3. #3
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Perhaps you need to first run the configure script which will create the Makefile for you

  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4
    I ran ./configure first and I checked the directory and saw Makefile.in listed there.

    I was trying to install Apache but the same problem occured when I attempted to install Python and also a BitTorrent thing. I used the installpkg tool for Python and then ./configure and then Make... no go. :- (

    These are the only things I've attempted to install so far and on each occasion I get this "no makefile found" error.

  5. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4
    for instance this is the README for Python:

    Congratulations on getting this far.

    To start building right away (on UNIX): type "./configure" in the
    current directory and when it finishes, type "make". This creates an
    executable "./python"; to install in /usr/local, first do "su root"
    and then "make install".

    I follow these instructions and get

    make: *** No targets specified and no makefile found. Stop.

    That's why I thought it might be a compiler issue, but gcc --version gives me

    gcc (GCC) 3.3.6
    .

    I'm at a loss. :- \

  6. #6
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Did configure spit out any errors? At the end it will say it's generated the Makefile (might say it multiple times). If it ran successfully, you will have a Makefile (not just a Makefile.in or a Makefile.am, you need one without an extension).

  7. #7
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4
    Yes, I got a "sanity check failure"...

    root@properganda:/Python-2.5.1#
    root@properganda:/Python-2.5.1#
    root@properganda:/Python-2.5.1# ./configure
    checking MACHDEP... linux2
    checking EXTRAPLATDIR...
    checking for --without-gcc... no
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for --with-cxx-main=<compiler>... no
    checking for g++... g++
    configure: WARNING:

    By default, distutils will build C++ extension modules with "g++".
    If this is not intended, then set CXX on the configure command line.

    checking how to run the C preprocessor... /lib/cpp
    configure: error: C preprocessor "/lib/cpp" fails sanity check
    See `config.log' for more details.

  8. #8
    Linux Newbie stinkoman's Avatar
    Join Date
    Jan 2008
    Location
    New Jersey
    Posts
    175
    did you try looking at config.log for more details? that might give you a hint.
    please click my minicity!
    or its industry more or even its roads
    Everyone is immortal until the day they die.
    Registered Linux user #462038

  9. #9
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1
    I came across this thread while having the same problem when installing apache 2.2.

    Installing kernel-headers, glibc, and binutils did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •