Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Hello, I recently installed Slackware 9.1 on my computer with 32mb ram, processor=133Mhz. It worked but I cant start the GUI. It only has a dos kind of screen. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    26

    How to start GUI in Slackware 9.1?


    Hello,

    I recently installed Slackware 9.1 on my computer with 32mb ram, processor=133Mhz. It worked but I cant start the GUI. It only has a dos kind of screen. I am new to Linux so please be gentle with words. I am happy to answer any new questions. Thanks in advance.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    32MB RAM is not enough for GUI. Try executing startx command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    26
    Are you sure, because the minimum requirements of slackware 9.1 is 16mb ram. As you can see, I have double the requirements. I have tries startx and it doen't work. Could you please tell me the command to open the setup of the slackware, what I mean is like the command equivalent of 'deliinstall' from deli linux.

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Here's a link showing some system requirements, but I'm not sure what version they are talking about:

    System Requirements

    Check the rest of that online book for lots good information on getting your Slackware install up and running.

    To delete Slack, you can simply install another distro right over it, or format, or delete the partitions.
    oz

  6. #5
    Just Joined! mattireland's Avatar
    Join Date
    Dec 2007
    Posts
    33
    Have you done xconfig ? You'll need to execute this before startx will work...

  7. #6
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    # Not familiar with 9.1

    Most people use the startx command, but I rather (as root) run telinit 4

    Some questions:
    When you did startx, was there an error message?
    Did you run it as user or as root?

    Have you set a default GUI during install (or rather, did you get that option)?

    Which GUI do you want to run??
    Can't tell an OS by it's GUI

  8. #7
    Just Joined!
    Join Date
    Jan 2008
    Posts
    26
    I have tried xconfig and it doesnt work.

  9. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Here's the X Configuration section from the SlackBook I posted above.

    Try it using that and let us know how it goes.
    oz

  10. #9
    Just Joined!
    Join Date
    Jan 2008
    Posts
    26
    I tried the commands given on the page but it simply doesn't work. I think it's because if u have a look at the top of the page, it says "from slackware ten onwards." I also tried the telinit 4. It said ::::

    ""starting X11......You do not have KDM, GDM or XDM installed....

    I want to use a lightweight window manager...maybe Fluxbox???

    REMINDER: I am using Slackware 9.1 and am extremely new to linux.
    Also, I didn't get any option about a GUI. Do you think I should re-install it?

  11. #10
    Linux Newbie stinkoman's Avatar
    Join Date
    Jan 2008
    Location
    New Jersey
    Posts
    175
    yeah seems like the disk didnt have any GUI on it, try downloading a newer version (unless youre set on 9.1 then just download a gui for it) that makes sense logically, but i dont have much experience
    please click my minicity!
    or its industry more or even its roads
    Everyone is immortal until the day they die.
    Registered Linux user #462038

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •