Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all i'm tring to install : slackware [Splashy] but whe i try to install freetype with ./freetype.SlackBuilds i get: Code: ..... Generating modules list in ./objs/ftmodule.h... * module: truetype ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162

    Unhappy C compiler cannot create executables


    Hi all
    i'm tring to install :
    slackware [Splashy]
    but whe i try to install freetype with ./freetype.SlackBuilds
    i get:
    Code:
    .....
    Generating modules list in ./objs/ftmodule.h...
    * module: truetype  (Windows/Mac font files with extension *.ttf or *.ttc)
    * module: type1     (Postscript font files with extension *.pfa or *.pfb)
    * module: cff       (OpenType fonts with extension *.otf)
    * module: cid       (Postscript CID-keyed fonts, no known extension)
    * module: pfr       (PFR/TrueDoc font files with extension *.pfr)
    * module: type42    (Type 42 font files with no known extension)
    * module: winfnt    (Windows bitmap fonts with extension *.fnt or *.fon)
    * module: pcf       (pcf bitmap fonts)
    * module: bdf       (bdf bitmap fonts)
    * module: sfnt      (helper module for TrueType & OpenType formats)
    * module: autofit   (automatic hinting module)
    * module: pshinter  (Postscript hinter module)
    * module: raster    (monochrome bitmap renderer)
    * module: smooth    (anti-aliased bitmap renderer)
    * module: smooth    (anti-aliased bitmap renderer for LCDs)
    * module: smooth    (anti-aliased bitmap renderer for vertical LCDs)
    * module: psaux     (Postscript Type 1 & Type 2 helper module)
    * module: psnames   (Postscript & Unicode Glyph name handling)
    done.
    cd builds/unix; ./configure --prefix=/usr i486-slackware-linux
    configure: WARNING: you should use --build, --host, --target
    checking build system type... i486-slackware-linux-gnu
    checking host system type... i486-slackware-linux-gnu
    checking target system type... i486-slackware-linux-gnu
    checking for i486-slackware-linux-gcc... i486-slackware-linux-gcc
    checking for C compiler default output file name...
    configure: error: C compiler cannot create executables
    See `config.log' for more details.
    make: *** [setup] Error 77
    config.mk:25: builds/unix/unix-def.mk: No such file or directory
    config.mk:26: builds/unix/unix-cc.mk: No such file or directory
    make: *** No rule to make target `builds/unix/unix-cc.mk'.  Stop.
    i installed binutils-2.17.50.0.17-i486-1, as suggested in onother forum
    then i tried to install glibc-2.7 /read someware that it might help/ but when i try:
    Code:
    ./configure --prefix=/usr/glibc-build
    i get:
    Code:
    configure: error: you must configure in a separate build directory
    although i used --prefix

    i'm stuck for 4 hours now...
    TIA

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Code:
    configure: error: C compiler cannot create executables
    See `config.log' for more details.
    Does config.log say anything useful? Might have to look around in it a bit, it's easy to get lost in config.log. Also, you don't have to specify i486-slackware-linux since your host and target machines are the same.

    I highly reccomend not trying to update glibc from source, that is not to be taken lightly and requires a higher level of expertise than it would appear you currently have. Doing it improperly can easily render your system unusable.

  3. #3
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    yes, after posting this i did more reading about the glibc, and decided that too big for me, but then i tried to install glib-2.12.12 /i have already installed it/, but i still get the same err as the freetype config...
    i tried to locate the config.log, but i only found the one for glib-2.12.12. i Couldent find the one for freetype, so i dont know what it says.

    i have not installed anything else so, i dont think that i messed up the gcc or something else

    EDIT: Here is the .log
    Attached Files Attached Files

  4. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    config.log should be created in the directory configure was run in, note that in this case it does a cd builds/unix first, though where that directory is located I can't tell.

    I noticed this in the log:
    Code:
    configure:2494: i486-slackware-linux-gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
    /usr/lib/gcc/i486-slackware-linux/4.1.2/../../../../i486-slackware-linux/bin/ld: cannot find /usr/lib/libc_nonshared.a
    Apparently libc_nonshared.a isn't found in /usr/lib . It would seem to me though that this should be found in /lib instead, do you have it there? If so, try making a symlink to /usr/lib and try again. You might have to run ldconfig after creating the symlink.

  5. #5
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    the file is missing.
    I tried to reinstall the nvidia driver, just to test the compiler, and it shows an err something like: "...The "CC" compiler could not create executables..."

    when i compiles glib2 i didnt understand the following:
    "Next you need to add –enable-static to your ./configure section and increment BUILD" and especially the "increment BUILD" part. i can't understand what to do with the BUILD part. Maybe this messed up the compiler...

  6. #6
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    I'm thinking you might need to reinstall the libc package, or maybe something like libc-static or libc-dev to get this libc_nonshared.a lib. As far as the "increment BUILD", I'm guessing there's a variable somewhere called BUILD that holds a number, which needs to have 1 added to it. Don't know where that variable might be though.

  7. #7
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    i'll try to install the libc package, but i was wondering about the BUILD option. Because if this messes up the glibc2 package than i wont be able to insstall it. i check the glibc2.SlackBuild script, also untared the glibc2 package just to see the config file but i couldent locate this BUILD option. i will write to Splashy team for this option.

    10x for your help valan.
    i'll try to reinstall the libc package, and post the result

  8. #8
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162

    Thumbs up Resolved

    ok
    i reinstalled the libc package from slackware dvd, and after that i changed the glib2.SlackBuild scrip to add to the configure --enable-static, and now it seems to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •