Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am trying out Vector Linux as it was recommended by various folks as fast, lightweight, stable and easy... Mostly I like it, blindingly fast and mostly easy to set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,499

    Boot without the wireless hoops...


    I am trying out Vector Linux as it was recommended by various folks as fast,
    lightweight, stable and easy...

    Mostly I like it, blindingly fast and mostly easy to set up. But, I do have one
    problem that I haven't been able to crack so far.

    Every time I boot, I have to reconfigure my wireless network, installing the
    driver for ndiswrapper and setting up the IP address, gateway etc. Once I have
    done this it works fine and I can get at the internal network and the Internet.
    In fact, I am typing this on my Vector Laptop using the wireless connection.

    How do I get it to load the driver and configure the network automatically
    when I boot so that I don't have to reinstall it every time?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    If Vector is like Slackware, you have in /etc/rc.d configuration files that you can edit to start up wireless instead of having to reconfigure every time. They are /etc/rc.d/rc.inet1.conf and /etc/rc.d/wireless.conf. Open each with your favourite editor and have a look. There will be places where you can uncomment certain parameters, (that is, take the '#' from the front of certain lines and configure them for your particular wireless situaion). Here are some good pages to further explain the process:

    Link 1
    Link 2

    I hope these help.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,499
    Thanks. I'll take a look at these tonight when I get home.

    As a further question, would it matter that I have put the Windows
    drivers for my card in my home directory?

    (I woke up this morning wondering about that - I am even geeky
    in my dreams!)
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by elija View Post
    As a further question, would it matter that I have put the Windows drivers for my card in my home directory?
    If you have installed and configured ndiswrapper correctly, (which you obviously have), it has already gotten the necessary .inf file from your Windows driver directory and installed it to /etc/ndiswrapper. That's where it will be called from. Not from where the Windows driver is in your home directory.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,499
    Yeah - the driver is there.

    At boot (and when I run the following) I get this

    /etc/rc.d/rc.inet1 start

    Starting network eth1 as 192.168.0.2/255.255.255.0...
    SIOCSIFADDR: No such device
    eth1: ERROR while getting interface flags: No such device
    SIOCSIFBRDADDR: No such device
    eth1: ERROR while getting interface flags: No such device
    SIOCSIFNETMASK: No such device

    I don't even know where to start....
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I think it may not be inserting ndiswrapper. After installing ndiswrapper, did you do the step:
    Code:
    ndiswrapper -m
    ?
    Look in /etc/modprobe.d. if there is no configuration file there called "ndiswrapper" you could go back and do the ndiswrapper -m step or create a configuration file called ndiswrapper in /etc/modprobe.d. In it you would put this or something like it:
    Code:
    alias wlan0 ndiswrapper
    I know Slackware 12 uses /etc/modprobe.d for that. Vector may possibly want that configuration in /etc/modprobe.conf which is the older way of doing it. Crux still uses modprobe.conf.

    EDIT: Can you post your /etc/rc.d/rc.inet1.conf here?
    Last edited by Dapper Dan; 01-14-2008 at 07:05 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #7
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,499
    This is /etc/modprobe.d/ndiswrapper
    alias eth1 ndiswrapper
    This is /etc/rc.d/rc/inet1

    #!/bin/sh
    # This file is supposed to be created by vnetadd
    # and modified by vnetset.
    # You can modify it by hand, but be careful
    #
    # GNU GPL (c) Eko M. Budi, 2004
    # (c) Vector Linux, 2004
    #

    ################################################## #########
    ## The settings
    DEVICE='eth1'
    DHCP='no'
    IPADDR='192.168.0.2'
    NETMASK='255.255.255.0'
    GATEWAY='192.168.0.1'
    PROBE='yes'

    ################################################## #########
    ## The script

    ## You may make customized script here
    ## If not, source the standard network
    . /etc/rc.d/functions-network "$@"

    This is /etc/rc.d/rc.inet.conf
    # /etc/rc.d/rc.inet1.conf
    #
    # This file contains the configuration settings for network interfaces.
    # If USE_DHCP[interface] is set to "yes", this overrides any other settings.
    # If you don't have an interface, leave the settings null ("").

    # You can configure network interfaces other than eth0,eth1... by setting
    # IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
    # or empty, it is assumed you're configuring eth<interface>.

    # Several other parameters are available, the end of this file contains a
    # comprehensive set of examples.

    # ================================================== ===========================

    # Config information for eth0:
    IPADDR[0]=""
    NETMASK[0]=""
    USE_DHCP[0]=""
    DHCP_HOSTNAME[0]=""

    # Config information for eth1:
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]=""
    DHCP_HOSTNAME[1]=""

    # Config information for eth2:
    IPADDR[2]=""
    NETMASK[2]=""
    USE_DHCP[2]=""
    DHCP_HOSTNAME[2]=""

    # Config information for eth3:
    IPADDR[3]=""
    NETMASK[3]=""
    USE_DHCP[3]=""
    DHCP_HOSTNAME[3]=""

    # Default gateway IP address:
    GATEWAY=""

    # Change this to "yes" for debugging output to stdout. Unfortunately,
    # /sbin/hotplug seems to disable stdout so you'll only see debugging output
    # when rc.inet1 is called directly.
    DEBUG_ETH_UP="no"

    ## Example config information for wlan0. Uncomment the lines you need and fill
    ## in your info. (You may not need all of these for your wireless network)
    #IFNAME[4]="wlan0"
    #IPADDR[4]=""
    #NETMASK[4]=""
    #USE_DHCP[4]="yes"
    #DHCP_HOSTNAME[4]="icculus-wireless"
    #DHCP_KEEPRESOLV[4]="yes"
    #DHCP_KEEPNTP[4]="yes"
    #DHCP_KEEPGW[4]="yes"
    #DHCP_IPADDR[4]=""
    #WLAN_ESSID[4]=BARRIER05
    #WLAN_MODE[4]=Managed
    ##WLAN_RATE[4]="54M auto"
    ##WLAN_CHANNEL[4]="auto"
    ##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
    ##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A 0EAFAD563B268BAD01CAF TxRate=0"
    #WLAN_WPA[4]="wpa_supplicant"
    #WLAN_WPADRIVER[4]="ndiswrapper"

    ## Some examples of additional network parameters that you can use.
    ## Config information for wlan0:
    #IFNAME[4]="wlan0" # Use a different interface name nstead of
    # the default 'eth4'
    #HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
    #MTU[4]="" # The default MTU is 1500, but you might need
    # 1360 when you use NAT'ed IPSec traffic.
    #DHCP_TIMEOUT[4]=15 # The default timeout for the DHCP client to
    # wait for server resonse is 60 seconds, but
    # you might want a shorter wait.
    #DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
    #DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
    #DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
    # your default gateway
    #DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
    # server
    #WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
    # defined in rc.wireless.conf, by prepending
    # 'WLAN_' to the parameter's name. Useful for
    # those with multiple wireless interfaces.
    #WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=thekey TxRate=0"
    # Some drivers require a private ioctl to be
    # set through the iwpriv command. If more than
    # one is required, you can place them in the
    # IWPRIV parameter (space-separated, see the
    # example).
    Hopefully, this is something easy...
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  8. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by elija View Post
    This is /etc/rc.d/rc/inet1
    Do you mean /etc/rc.d/rc.inet1? I guess Vector is configuring rc.inet1 instead of rc.inet1.conf. So that's the file I guess you should concentrate on. The thing that seems amiss to me is that ndiswrapper is configured for eth1. When you are configuring your wireless by hand are you configuring it as eth1? In the cases where I've dealt with it, ndiswrapper finds wireless devices at wlan0. Are these settings correct?
    Code:
    DHCP='no'
    IPADDR='192.168.0.2'
    NETMASK='255.255.255.0'
    GATEWAY='192.168.0.1'
    PROBE='yes'
    If so, let's try this first:

    Edit both /etc/modprobe.d/ndiswrapper AND /etc/rc.d/rc.inet1. In both files change eth1 to wlan0. You will do this with your favourite editor as su. After making the changes, save and exit. Reboot and see if your wireless gets configured properly. After getting rebooted up and going, run from a terminal as su:
    Code:
    /sbin/iwconfig
    And
    Code:
    /sbin/ifconfig
    And post the results here. Doing this *may* fix your problem. Then again, it may not. If it doesn't, we can begin looking elsewhere.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #9
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,499
    eth1 is assigned when I configure it using the VASMCC gui tool.
    I'm sufing with that config now.

    Code:
    root:# ifconfig
    eth1      Link encap:Ethernet  HWaddr 00:19:D2:70:D6:9E  
              inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:18 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 b)  TX bytes:34 (34.0 b)
              Interrupt:17 Base address:0x4000 Memory:ff9ff000-ff9fffff 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    
    root:# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11g  ESSID:"Home54"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:B5:56:83:50   
              Bit Rate:54 Mb/s   Tx-Power:15 dBm   
              Retry limit:15   RTS thr:off   Fragment thr:off
              Encryption key:AAED-DB2C-1C95-115B-7E7B-6CB0-3694-CF2B-C32D-C596-A4EC-51D6-CAF8-8C59-03A4-BD21   Security mode:open
              Power Management:off
              Link Quality=86/100  Signal level=-47 dBm  Noise level=-48 dBm
              Rx invalid nwid:0  Rx invalid crypt:2  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:19   Missed beacon:0
    I also found this in /etc/rc.d/rc.boot.inet. I don't know how relevant it is

    Code:
    #         (c) Vector Linux, 2004
    
    INET=${2:-"inet0"}
    
    IPADDR=""
    NETMASK=""
    GATEWAY=""
    DHCP=""
    DEVICE=""
    
    export PATH="/sbin:/usr/sbin:/bin:/usr/bin"
    
    for CMD in `cat /proc/cmdline`; do
    #  echo $CL
      KEY=${CMD%=*}
      VAL=${CMD#*=}
      if [ "$KEY" = "$INET" ]; then
        DEVICE=`echo $VAL | cut -f 1 -d ','`
        DHCP=`echo $VAL | cut -f 2 -d ','`
        if [ "$DHCP" = "dhcp" ]; then
          DHCP="yes"
          . /etc/rc.d/functions-network $1
          exit $?
        else
          IPADDR=$DHCP
          DHCP="no"
          NETMASK=`echo $VAL | cut -f 3 -d ','`
          GATEWAY=`echo $VAL | cut -f 4 -d ','`
          PROBE=`echo $VAL | cut -f 5 -d ','`
          . /etc/rc.d/functions-network $1
          exit $?
        fi
      fi
    done
    exit 1
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  10. #10
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I'm wondering if another wireless driver is getting loaded giving you eth1. If that is the case, you may need to blacklist a driver. Can you post the results of:
    Code:
    /sbin/lsmod
    Also, lets see:
    Code:
    /sbin/lspci
    So I can see your exact wireless device. I'm kind of flying in the dark as I just have never used Vector and am not aware of the exact way they do things. Do they provide you with a wireless configuration utility?
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •